Skip to content
Laskyr

Plugins · wpzoom-elementor-addons · data as of 2026-11-04

Is WPZOOM Addons for Elementor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.17)

As of 2026-11-04. 7 issues are on record for older versions; version 1.3.5 or newer fixes all of them that state a fix.

Latest version
1.4.17
Last updated
2026-11-03
Active installs
20,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Elementor templates and widgets - Import professionally designed page templates, sections, and widgets. Build stunning pages in minutes. — by WPZOOM

What to do

  1. Update to the latest version (1.4.17). Anything older than 1.3.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpzoom-elementor-addons --field=version shows what you run; wp plugin update wpzoom-elementor-addons updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-39597 · published 2026-06-17

Cross-site scripting (XSS) in WPZOOM Addons for Elementor (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.3.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in WPZOOM Addons for Elementor <= 1.3.4 versions.

NVD CVE-2026-39597Patchstack advisory

medium 5.3 CVE-2026-2295 · published 2026-02-11

Missing authorization check in WPZOOM Addons for Elementor (1.3.2 and older)

Affected
1.3.2 and older
Fixed in
1.3.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPZOOM Addons for Elementor – Starter Templates & Widgets plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'ajax_post_grid_load_more' function in all versions up to, and including, 1.3.2. This makes it possible for unauthenticated attackers to retrieve protected (draft, future, pending) post titles and excerpts that should not be accessible to unauthenticated users.

NVD CVE-2026-2295Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-67951 · published 2025-12-16

Cross-site scripting (XSS) in WPZOOM Addons for Elementor (1.2.10 and older)

Affected
1.2.10 and older
Fixed in
1.2.11
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPZOOM WPZOOM Addons for Elementor wpzoom-elementor-addons allows DOM-Based XSS.This issue affects WPZOOM Addons for Elementor: from n/a through <= 1.2.10.

NVD CVE-2025-67951Patchstack advisory

medium 5.4 CVE-2024-5686 · published 2024-06-20

Stored cross-site scripting (XSS) in WPZOOM Addons for Elementor (1.1.38 and older)

Affected
1.1.38 and older
Fixed in
1.1.39 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WPZOOM Addons for Elementor (Templates, Widgets) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘url’ attribute within the plugin's Team Members widget in all versions up to, and including, 1.1.38 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-5686Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2024-5147 · published 2024-05-22

File inclusion in WPZOOM Addons for Elementor (1.1.37 and older)

Affected
1.1.37 and older
Fixed in
1.1.38 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPZOOM Addons for Elementor (Templates, Widgets) plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.1.37 via the 'grid_style' parameter. This makes it possible for unauthenticated attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.

NVD CVE-2024-5147Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-4370 · published 2024-05-15

Stored cross-site scripting (XSS) in WPZOOM Addons for Elementor (1.1.36 and older)

Affected
1.1.36 and older
Fixed in
1.1.37 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WPZOOM Addons for Elementor (Templates, Widgets) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's widget Image Box in all versions up to, and including, 1.1.36 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-4370Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.4 CVE-2024-33539 · published 2024-04-29

Stored cross-site scripting (XSS) in WPZOOM Addons for Elementor (1.1.35 and older)

Affected
1.1.35 and older
Fixed in
1.1.36
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPZOOM WPZOOM Addons for Elementor (Templates, Widgets) allows Stored XSS.This issue affects WPZOOM Addons for Elementor (Templates, Widgets): from n/a through 1.1.35.

NVD CVE-2024-33539Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPZOOM Addons for Elementor vulnerability status badge
<a href="https://laskyr.com/plugins/wpzoom-elementor-addons"><img src="https://laskyr.com/plugins/wpzoom-elementor-addons/badge.svg" alt="WPZOOM Addons for Elementor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit