Plugins · wpvivid-backup-mainwp · data as of 2026-11-04
Is WPvivid Backup for MainWP safe? Known vulnerabilities and latest version
- Latest version
- 0.9.42
- Last updated
- 2026-08-06
- Active installs
- 10,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 5.3+
Set up and control WPvivid Backup Free and Pro for all child sites directly from your MainWP Dashboard. — by wpvividplugins
What to do
- Update to the latest version (0.9.42). Anything older than 0.9.34 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wpvivid-backup-mainwp --field=version shows what you run; wp plugin update wpvivid-backup-mainwp updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.4 CVE-2026-15283 · published 2026-07-10
Stored cross-site scripting (XSS) in WPvivid Backup for MainWP (0.9.33 and older)
- Affected
- 0.9.33 and older
- Fixed in
- 0.9.34 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WPvivid Backup for MainWP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 0.9.33 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
medium 6.1 CVE-2024-35664 · published 2024-06-04
Reflected cross-site scripting (XSS) in WPvivid Backup for MainWP (0.9.32 and older)
- Affected
- 0.9.32 and older
- Fixed in
- 0.9.33
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpvividplugins WPvivid Backup for MainWP wpvivid-backup-mainwp allows Reflected XSS.This issue affects WPvivid Backup for MainWP: from n/a through <= 0.9.32.
medium 6.1 CVE-2024-1383 · published 2024-03-13
Reflected cross-site scripting (XSS) in WPvivid Backup for MainWP (0.9.32 and older)
- Affected
- 0.9.32 and older
- Fixed in
- 0.9.33 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WPvivid Backup for MainWP plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'id' parameter in all versions up to, and including, 0.9.32 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link. CVE-2024-35664 is likely a duplicate of this issue.
NVD CVE-2024-1383Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-08-06 — latest release on wordpress.org (0.9.42).
- 2026-07-10 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15283), fixed in 0.9.34.
- 2024-06-04 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-35664), fixed in 0.9.33.
- 2024-03-13 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-1383), fixed in 0.9.33.
Get an email when WPvivid Backup for MainWP has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WPvivid Backup for MainWP (wpvivid-backup-mainwp) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by wpvividplugins (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wpvivid-backup-mainwp (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wpvivid-backup-mainwp"><img src="https://laskyr.com/plugins/wpvivid-backup-mainwp/badge.svg" alt="WPvivid Backup for MainWP vulnerability status"></a>