Skip to content
Laskyr

Plugins · wpsynchro · data as of 2026-11-04

Is WP Synchro safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.16.2)

As of 2026-11-04. 3 issues are on record for older versions; version 1.16.2 or newer fixes all of them that state a fix.

Latest version
1.16.2
Last updated
2026-10-31
Active installs
2,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WordPress migration plugin to easily migrate, clone, backup, and synchronize your WordPress site, including database, media, plugins, themes, and file … — by WP Synchro

What to do

  1. Update to the latest version (1.16.2). Anything older than 1.16.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpsynchro --field=version shows what you run; wp plugin update wpsynchro updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-41558 · published 2026-10-06

Security issue in WP Synchro (1.16.1 and older)

Affected
1.16.1 and older
Fixed in
1.16.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Bypass Vulnerability in WP Migration Plugin DB & Files – WP Synchro <= 1.16.1 versions.

NVD CVE-2026-41558Patchstack advisory

medium 5.4 CVE-2024-32096 · published 2024-04-15

Cross-site request forgery (CSRF) in WP Synchro (1.11.2 and older)

Affected
1.11.2 and older
Fixed in
1.11.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in DAEV.Tech WP Migration Plugin DB & Files – WP Synchro.This issue affects WP Migration Plugin DB & Files – WP Synchro: from n/a through 1.11.2.

NVD CVE-2024-32096Patchstack advisory

high 8.8 CVE-2023-41660 · published 2023-10-09

Cross-site request forgery (CSRF) in WP Synchro (1.9.1 and older)

Affected
1.9.1 and older
Fixed in
1.10.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WPSynchro WP Synchro plugin <= 1.9.1 versions.

NVD CVE-2023-41660Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Synchro vulnerability status badge
<a href="https://laskyr.com/plugins/wpsynchro"><img src="https://laskyr.com/plugins/wpsynchro/badge.svg" alt="WP Synchro vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit