Skip to content
Laskyr

Plugins · wpstream · data as of 2026-11-04

Is WpStream safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.14.3)

As of 2026-11-04. 6 issues are on record for older versions; version 4.11.2 or newer fixes all of them that state a fix.

Latest version
4.14.3
Last updated
2026-10-19
Active installs
3,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.1+

WpStream is a Video Streaming Plugin that lets you broadcast live events and helps you sell tickets or recordings via WooCommerce. — by wpstream

What to do

  1. Update to the latest version (4.14.3). Anything older than 4.11.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpstream --field=version shows what you run; wp plugin update wpstream updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2026-39527 · published 2026-06-15

Arbitrary file upload in WpStream (older than 4.11.2)

Affected
older than 4.11.2
Fixed in
4.11.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Arbitrary File Upload in WpStream < 4.11.2 versions.

NVD CVE-2026-39527Patchstack advisory

medium 5.4 CVE-2026-39526 · published 2026-04-08

Missing authorization check in WpStream (4.11.2 and older)

Affected
4.11.2 and older
Fixed in
4.11.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Authorization Bypass Through User-Controlled Key vulnerability in wpstream WpStream wpstream allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WpStream: from n/a through < 4.11.2.

NVD CVE-2026-39526Patchstack advisory

medium 5.3 CVE-2025-68521 · published 2025-12-24

Missing authorization check in WpStream (4.9.5 and older)

Affected
4.9.5 and older
Fixed in
4.9.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in wpstream WpStream wpstream allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WpStream: from n/a through <= 4.9.5.

NVD CVE-2025-68521Patchstack advisory

medium 4.3 CVE-2025-68522 · published 2025-12-24

Missing authorization check in WpStream (4.9.5 and older)

Affected
4.9.5 and older
Fixed in
4.9.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in wpstream WpStream wpstream allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WpStream: from n/a through <= 4.9.5.

NVD CVE-2025-68522Patchstack advisory

high 8.8 CVE-2023-27458 · published 2023-11-22

Cross-site request forgery (CSRF) in WpStream (4.4.10 and older)

Affected
4.4.10 and older
Fixed in
4.4.10.6
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in wpstream WpStream plugin <= 4.4.10 versions.

NVD CVE-2023-27458Patchstack advisory

high 8.8 CVE-2023-38512 · published 2023-07-27

Cross-site request forgery (CSRF) in WpStream (4.5.4 and older)

Affected
4.5.4 and older
Fixed in
4.5.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in wpstream WpStream wpstream allows Cross Site Request Forgery.This issue affects WpStream: from n/a through <= 4.5.4.

NVD CVE-2023-38512Patchstack advisoryPatchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WpStream vulnerability status badge
<a href="https://laskyr.com/plugins/wpstream"><img src="https://laskyr.com/plugins/wpstream/badge.svg" alt="WpStream vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit