Plugins · wpshop · data as of 2026-11-04
Is WPshop 2 safe? Known vulnerabilities and latest version
- Latest version
- 2.6.1
- Last updated
- 2025-05-16
- Active installs
- 30+
- Known issues on record
- 5
- Unpatched in latest
- 2
- Tested up to WP
- 6.8.12 · PHP 7.4.33+
Simple and powerfull ECommerce plugin for WordPress — by Agence web Eoxia - Montpellier
What to do
- There is no fixed version yet. If you can live without WPshop 2 for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get wpshop --field=version shows what you run; wp plugin update wpshop updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 affects latest 2.6.1 CVE-2025-69383 · published 2026-02-20
File inclusion in WPshop 2 (2.6.1 and older)
- Affected
- 2.6.1 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Agence web Eoxia - Montpellier WP shop wpshop allows PHP Local File Inclusion.This issue affects WP shop: from n/a through <= 2.6.1.
critical 9.8 CVE-2015-10135 · published 2025-07-19
Arbitrary file upload in WPshop 2 (older than 1.3.9.6)
- Affected
- older than 1.3.9.6
- Fixed in
- 1.3.9.6
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WPshop 2 – E-Commerce plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the ajaxUpload function in versions before 1.3.9.6. This makes it possible for unauthenticated attackers to upload arbitrary files on the affected sites server which may make remote code execution possible.
NVD CVE-2015-10135Wordfence advisoryCode change (fix)wordpress.orgg0blin.co.ukgithub.com
medium 6.5 CVE-2025-3853 · published 2025-05-07
Missing authorization check in WPshop 2 (2.0.0 to 2.6.0)
- Affected
- 2.0.0 to 2.6.0
- Fixed in
- 2.6.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WPshop 2 – E-Commerce plugin for WordPress is vulnerable to Insecure Direct Object Reference in versions 2.0.0 to 2.6.0 via the callback_generate_api_key() due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create valid API keys on behalf of other users.
high 8.8 CVE-2025-3852 · published 2025-05-07
Privilege escalation in WPshop 2 (2.0.0 to 2.6.0)
- Affected
- 2.0.0 to 2.6.0
- Fixed in
- 2.6.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WPshop 2 – E-Commerce plugin for WordPress is vulnerable to privilege escalation via account takeover in versions 2.0.0 to 2.6.0. This is due to the plugin not properly validating a user's identity prior to updating their details like email & password through the update() function. This makes it possible for authenticated attackers, with subscriber-level access and above, to change arbitrary user's passwords, including administrators, and leverage that to gain access to their account.
critical 9.6 affects latest 2.6.1 CVE-2025-32576 · published 2025-04-09
Cross-site request forgery (CSRF) in WPshop 2 (2.6.1 and older)
- Affected
- 2.6.1 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in Agence web Eoxia - Montpellier WP shop wpshop allows Upload a Web Shell to a Web Server.This issue affects WP shop: from n/a through <= 2.6.1.
Recent activity
- 2025-05-16 — latest release on wordpress.org (2.6.1).
- 2026-02-20 — File inclusion disclosed (CVE-2025-69383), no fix listed yet.
- 2025-07-19 — Arbitrary file upload disclosed (CVE-2015-10135), fixed in 1.3.9.6.
- 2025-05-07 — Missing authorization check disclosed (CVE-2025-3853), fixed in 2.6.1.
Get an email when WPshop 2 has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WPshop 2 (wpshop) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: File inclusion (1) · Arbitrary file upload (1) · Missing authorization (1) · Privilege escalation (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wpshop (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wpshop"><img src="https://laskyr.com/plugins/wpshop/badge.svg" alt="WPshop 2 vulnerability status"></a>