Skip to content
Laskyr

Plugins · wps-hide-login · data as of 2026-11-01

Is WPS Hide Login safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.19)

As of 2026-11-01. 10 issues are on record for older versions; version 1.9.16.4 or newer fixes all of them that state a fix.

Latest version
1.9.19
Last updated
2026-08-13
Active installs
2+ million
Known issues on record
10
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Change wp-login.php to anything you want. — by Remy Perona

What to do

  1. Update to the latest version (1.9.19). Anything older than 1.9.16.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wps-hide-login --field=version shows what you run; wp plugin update wps-hide-login updates it.

Check your version

Known vulnerabilities

10 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2024-6289 · published 2024-07-15

Open redirect in WPS Hide Login (older than 1.9.16.4)

Affected
older than 1.9.16.4
Fixed in
1.9.16.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WPS Hide Login WordPress plugin before 1.9.16.4 does not prevent redirects to the login page via the auth_redirect WordPress function, allowing an unauthenticated visitor to access the hidden login page.

NVD CVE-2024-6289WPScan advisory

medium 5.3 CVE-2024-2473 · published 2024-06-11

Missing authorization check in WPS Hide Login (1.9.15.2 and older)

Affected
1.9.15.2 and older
Fixed in
1.9.16 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPS Hide Login plugin for WordPress is vulnerable to Login Page Disclosure in all versions up to, and including, 1.9.15.2. This is due to a bypass that is created when the 'action=postpass' parameter is supplied. This makes it possible for attackers to easily discover any login page that may have been hidden by the plugin.

NVD CVE-2024-2473Wordfence advisoryCode change (fix)github.com

low 3.7 CVE-2023-49748 · published 2024-06-04

Information disclosure in WPS Hide Login (1.9.11 and older)

Affected
1.9.11 and older
Fixed in
1.9.12
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in WPServeur, NicolasKulka, wpformation WPS Hide Login allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects WPS Hide Login: from n/a through 1.9.11.

NVD CVE-2023-49748Patchstack advisory

high 7.5 CVE-2020-36710 · published 2023-06-07

Missing authorization check in WPS Hide Login (1.5.4.2 and older)

Affected
1.5.4.2 and older
Fixed in
1.5.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WPS Hide Login plugin for WordPress is vulnerable to login page disclosure even when the settings of the plugin are set to hide the login page making it possible for unauthenticated attackers to brute force credentials on sites in versions up to, and including, 1.5.4.2.

NVD CVE-2020-36710Wordfence advisoryblog.nintechnet.com

high 7.5 CVE-2021-24917 · published 2021-12-06

Missing authorization check in WPS Hide Login (older than 1.9.1)

Affected
older than 1.9.1
Fixed in
1.9.1
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The WPS Hide Login WordPress plugin before 1.9.1 has a bug which allows to get the secret login page by setting a random referer string and making a request to /wp-admin/options.php as an unauthenticated user.

NVD CVE-2021-24917WPScan advisorywordpress.org

high 8.8 CVE-2015-9498 · published 2019-10-22

Cross-site request forgery (CSRF) in WPS Hide Login (older than 1.1)

Affected
older than 1.1
Fixed in
1.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The wps-hide-login plugin before 1.1 for WordPress has CSRF that affects saving an option value.

NVD CVE-2015-9498wordpress.orgwpvulndb.com

critical 9.8 CVE-2019-15826 · published 2019-08-30

Security issue in WPS Hide Login (older than 1.5.3)

Affected
older than 1.5.3
Fixed in
1.5.3
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The wps-hide-login plugin before 1.5.3 for WordPress has a protection bypass via wp-login.php in the Referer field.

NVD CVE-2019-15826wordpress.orgsecupress.mewpvulndb.com

critical 9.8 CVE-2019-15823 · published 2019-08-30

Security issue in WPS Hide Login (older than 1.5.3)

Affected
older than 1.5.3
Fixed in
1.5.3
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The wps-hide-login plugin before 1.5.3 for WordPress has an action=confirmaction protection bypass.

NVD CVE-2019-15823wordpress.orgsecupress.mewpvulndb.com

critical 9.8 CVE-2019-15824 · published 2019-08-30

Security issue in WPS Hide Login (older than 1.5.3)

Affected
older than 1.5.3
Fixed in
1.5.3
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The wps-hide-login plugin before 1.5.3 for WordPress has an adminhash protection bypass.

NVD CVE-2019-15824wordpress.orgsecupress.mewpvulndb.com

critical 9.8 CVE-2019-15825 · published 2019-08-30

Security issue in WPS Hide Login (older than 1.5.3)

Affected
older than 1.5.3
Fixed in
1.5.3
Access needed (per CVSS)
No login needed
Range from
NVD analysis · score by NVD
Details from the advisory

The wps-hide-login plugin before 1.5.3 for WordPress has an action=rp&key&login protection bypass.

NVD CVE-2019-15825wordpress.orgsecupress.mewpvulndb.com

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPS Hide Login vulnerability status badge
<a href="https://laskyr.com/plugins/wps-hide-login"><img src="https://laskyr.com/plugins/wps-hide-login/badge.svg" alt="WPS Hide Login vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit