Skip to content
Laskyr

Plugins · wppizza · data as of 2026-11-04

Is WPPizza safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.20.1)

As of 2026-11-04. 7 issues are on record for older versions; version 3.20 or newer fixes all of them that state a fix.

Latest version
3.20.1
Last updated
2026-06-09
Active installs
900+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.3+

A Restaurant Plugin (not only for Pizza). Maintain your Menu (sizes, prices, categories). Accept COD orders. Multisite, Multilingual, WPML compatible. — by ollybach

What to do

  1. Update to the latest version (3.20.1). Anything older than 3.20 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wppizza --field=version shows what you run; wp plugin update wppizza updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-40796 · published 2026-06-15

Information disclosure in WPPizza (3.19.9 and older)

Affected
3.19.9 and older
Fixed in
3.20
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Sensitive Data Exposure in WPPizza <= 3.19.9 versions.

NVD CVE-2026-40796Patchstack advisory

medium 4.3 CVE-2025-57894 · published 2025-08-22

Missing authorization check in WPPizza (3.19.8 and older)

Affected
3.19.8 and older
Fixed in
3.19.8.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in ollybach WPPizza wppizza allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WPPizza: from n/a through <= 3.19.8.

NVD CVE-2025-57894Patchstack advisory

high 7.1 CVE-2025-26991 · published 2025-02-25

Reflected cross-site scripting (XSS) in WPPizza (3.19.4 and older)

Affected
3.19.4 and older
Fixed in
3.19.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in ollybach WPPizza wppizza allows Reflected XSS.This issue affects WPPizza: from n/a through <= 3.19.4.

NVD CVE-2025-26991Patchstack advisory

medium 6.1 CVE-2024-35766 · published 2024-06-21

Reflected cross-site scripting (XSS) in WPPizza (3.18.13 and older)

Affected
3.18.13 and older
Fixed in
3.18.14
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in ollybach WPPizza allows Reflected XSS.This issue affects WPPizza: from n/a through 3.18.13.

NVD CVE-2024-35766Patchstack advisory

medium 6.5 CVE-2024-33576 · published 2024-05-06

Missing authorization check in WPPizza (3.18.10 and older)

Affected
3.18.10 and older
Fixed in
3.18.11
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Ollybach WPPizza.This issue affects WPPizza: from n/a through 3.18.10.

NVD CVE-2024-33576Patchstack advisory

medium 6.1 CVE-2023-46622 · published 2023-10-31

Reflected cross-site scripting (XSS) in WPPizza (3.18.2 and older)

Affected
3.18.2 and older
Fixed in
3.18.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in ollybach WPPizza – A Restaurant Plugin plugin <= 3.18.2 versions.

NVD CVE-2023-46622Patchstack advisory

medium 6.1 CVE-2023-32105 · published 2023-08-18

Reflected cross-site scripting (XSS) in WPPizza (3.17.1 and older)

Affected
3.17.1 and older
Fixed in
3.17.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in ollybach WPPizza – A Restaurant Plugin plugin <= 3.17.1 versions.

NVD CVE-2023-32105Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPPizza vulnerability status badge
<a href="https://laskyr.com/plugins/wppizza"><img src="https://laskyr.com/plugins/wppizza/badge.svg" alt="WPPizza vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit