Plugins · wpo365-msgraphmailer · data as of 2026-11-04
Is WPO365 safe? Known vulnerabilities and latest version
- Latest version
- 6.3
- Last updated
- 2026-10-18
- Active installs
- 10,000+
- Known issues on record
- 2
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Send WordPress emails from a M365 / Exchange Online Mailbox using Microsoft Graph, leveraging OAuth for authentication which is more secure than SMTP — by Marco van Wieren
What to do
- Update to the latest version (6.3). Anything older than 6.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wpo365-msgraphmailer --field=version shows what you run; wp plugin update wpo365-msgraphmailer updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-107759 · published 2026-10-31
Stored cross-site scripting (XSS) in WPO365 (6.2 and older)
- Affected
- 6.2 and older
- Fixed in
- 6.3 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WPO365 | MICROSOFT 365 GRAPH MAILER plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Subject (via wp_mail/PHPMailer, e.g. CF7 your-subject)' parameter in all versions up to, and including, 6.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload is stored without authentication via any mail-sending feature that forwards a submitter-controlled subject (e.g. a Contact Form 7 form) when the Graph Mailer is enabled but OAuth authorization has not been completed, a default state immediately after plugin activation.
NVD CVE-2026-107759Wordfence advisoryCode change (fix)Plugin source
medium 6.1 CVE-2025-1488 · published 2025-02-24
Open redirect in WPO365 (3.2 and older)
- Affected
- 3.2 and older
- Fixed in
- 3.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WPO365 | MICROSOFT 365 GRAPH MAILER plugin for WordPress is vulnerable to Open Redirect in all versions up to, and including, 3.2. This is due to insufficient validation on the redirect url supplied via the 'redirect_to' parameter. This makes it possible for unauthenticated attackers to redirect users to potentially malicious sites if 1. they can successfully trick them into performing an action and 2. the plugin is activated but not configured.
NVD CVE-2025-1488Wordfence advisoryCode change (fix)wordpress.orgwpo365.com
Recent activity
- 2026-10-18 — latest release on wordpress.org (6.3).
- 2026-10-31 — Stored cross-site scripting (XSS) disclosed (CVE-2026-107759), fixed in 6.3.
- 2025-02-24 — Open redirect disclosed (CVE-2025-1488), fixed in 3.3.
Get an email when WPO365 has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WPO365 (wpo365-msgraphmailer) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Marco van Wieren (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Open redirect (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wpo365-msgraphmailer (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wpo365-msgraphmailer"><img src="https://laskyr.com/plugins/wpo365-msgraphmailer/badge.svg" alt="WPO365 vulnerability status"></a>