Skip to content
Laskyr

Plugins · wpkoi-templates-for-elementor · data as of 2026-11-04

Is WPKoi Templates for Elementor safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.7.4)

As of 2026-11-04. 7 issues are on record for older versions; version 3.7.3 or newer fixes all of them that state a fix.

Latest version
3.7.4
Last updated
2026-10-10
Active installs
5,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Unlock 400+ stunning Elementor templates that transform your website into a visual masterpiece. Compatible with popular WordPress themes. — by wpkoithemes

What to do

  1. Update to the latest version (3.7.4). Anything older than 3.7.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpkoi-templates-for-elementor --field=version shows what you run; wp plugin update wpkoi-templates-for-elementor updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-85302 · published 2026-09-03

Cross-site scripting (XSS) in WPKoi Templates for Elementor (3.7.2 and older)

Affected
3.7.2 and older
Fixed in
3.7.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPKoi WordPress Themes WPKoi Templates for Elementor allows DOM-Based XSS. This issue affects WPKoi Templates for Elementor: from n/a through 3.7.2.

NVD CVE-2026-85302Patchstack advisory

medium 4.3 CVE-2025-64274 · published 2025-11-13

Missing authorization check in WPKoi Templates for Elementor (3.4.4 and older)

Affected
3.4.4 and older
Fixed in
3.4.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in wpkoithemes WPKoi Templates for Elementor wpkoi-templates-for-elementor allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WPKoi Templates for Elementor: from n/a through <= 3.4.4.

NVD CVE-2025-64274Patchstack advisory

medium 6.5 CVE-2025-57999 · published 2025-09-22

Cross-site scripting (XSS) in WPKoi Templates for Elementor (3.4.3 and older)

Affected
3.4.3 and older
Fixed in
3.4.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpkoithemes WPKoi Templates for Elementor wpkoi-templates-for-elementor allows DOM-Based XSS.This issue affects WPKoi Templates for Elementor: from n/a through <= 3.4.3.

NVD CVE-2025-57999Patchstack advisory

medium 6.5 CVE-2024-56241 · published 2025-01-02

Stored cross-site scripting (XSS) in WPKoi Templates for Elementor (3.1.3 and older)

Affected
3.1.3 and older
Fixed in
3.1.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpkoithemes WPKoi Templates for Elementor wpkoi-templates-for-elementor allows Stored XSS.This issue affects WPKoi Templates for Elementor: from n/a through <= 3.1.3.

NVD CVE-2024-56241Patchstack advisory

medium 5.4 CVE-2024-49679 · published 2024-10-29

Stored cross-site scripting (XSS) in WPKoi Templates for Elementor (3.1.0 and older)

Affected
3.1.0 and older
Fixed in
3.1.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpkoithemes WPKoi Templates for Elementor wpkoi-templates-for-elementor allows Stored XSS.This issue affects WPKoi Templates for Elementor: from n/a through <= 3.1.0.

NVD CVE-2024-49679Patchstack advisory

medium 6.4 CVE-2024-4980 · published 2024-05-22

Stored cross-site scripting (XSS) in WPKoi Templates for Elementor (2.5.9 and older)

Affected
2.5.9 and older
Fixed in
2.5.10 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPKoi Templates for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'id', 'mixColor', 'backgroundColor', 'saveInCookies', and 'autoMatchOsTheme' parameters in all versions up to, and including, 2.5.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-4980Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-2136 · published 2024-03-07

Stored cross-site scripting (XSS) in WPKoi Templates for Elementor (2.5.6 and older)

Affected
2.5.6 and older
Fixed in
2.5.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WPKoi Templates for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Advanced Heading widget in all versions up to, and including, 2.5.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-2136Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPKoi Templates for Elementor vulnerability status badge
<a href="https://laskyr.com/plugins/wpkoi-templates-for-elementor"><img src="https://laskyr.com/plugins/wpkoi-templates-for-elementor/badge.svg" alt="WPKoi Templates for Elementor vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit