Plugins · wpjam-basic · data as of 2026-11-04
Is WPJAM Basic safe? Known vulnerabilities and latest version
- Latest version
- 7.1.2
- Last updated
- 2026-10-03
- Active installs
- 4,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
WPJAM Basic 是我爱水煮鱼博客多年来使用 WordPress 来整理的优化插件,WPJAM Basic 除了能够优化你的 WordPress,也是 WordPress 果酱团队进行 WordPress 二次开发的基础。 — by denishua
What to do
- Update to the latest version (7.1.2). Anything older than 7.0.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wpjam-basic --field=version shows what you run; wp plugin update wpjam-basic updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-66432 · published 2026-08-13
Information disclosure in WPJAM Basic (7.0.2.1 and older)
- Affected
- 7.0.2.1 and older
- Fixed in
- 7.0.3
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber Sensitive Data Exposure in WPJAM Basic <= 7.0.2.1 versions.
critical 9.3 CVE-2026-61966 · published 2026-08-13
SQL injection in WPJAM Basic (7.0.1 and older)
- Affected
- 7.0.1 and older
- Fixed in
- 7.0.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber SQL Injection in WPJAM Basic <= 7.0.1 versions.
high 8.8 CVE-2026-57371 · published 2026-07-13
PHP object injection in WPJAM Basic (7.0 and older)
- Affected
- 7.0 and older
- Fixed in
- 7.0.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in denishua WPJAM Basic wpjam-basic allows Object Injection.This issue affects WPJAM Basic: from n/a through <= 7.0.
high 7.2 CVE-2026-57372 · published 2026-07-13
Server-side request forgery (SSRF) in WPJAM Basic (7.0 and older)
- Affected
- 7.0 and older
- Fixed in
- 7.0.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Server-Side Request Forgery (SSRF) vulnerability in denishua WPJAM Basic wpjam-basic allows Server Side Request Forgery.This issue affects WPJAM Basic: from n/a through <= 7.0.
critical 9.9 CVE-2026-32523 · published 2026-03-25
Arbitrary file upload in WPJAM Basic (6.9.2 and older)
- Affected
- 6.9.2 and older
- Fixed in
- 6.9.2.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- advisory text · score by Patchstack
Details from the advisory
Unrestricted Upload of File with Dangerous Type vulnerability in denishua WPJAM Basic wpjam-basic allows Using Malicious Files.This issue affects WPJAM Basic: from n/a through <= 6.9.2.
medium 5.4 CVE-2023-23709 · published 2023-05-16
Stored cross-site scripting (XSS) in WPJAM Basic (6.2.1 and older)
- Affected
- 6.2.1 and older
- Fixed in
- 6.2.1.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Denis WPJAM Basic plugin <= 6.2.1 versions.
Recent activity
- 2026-10-03 — latest release on wordpress.org (7.1.2).
- 2026-08-13 — Information disclosure disclosed (CVE-2026-66432), fixed in 7.0.3.
- 2026-08-13 — SQL injection disclosed (CVE-2026-61966), fixed in 7.0.2.
- 2026-07-13 — PHP object injection disclosed (CVE-2026-57371), fixed in 7.0.1.
Get an email when WPJAM Basic has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WPJAM Basic (wpjam-basic) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Sensitive data exposure (1) · SQL injection (1) · PHP object injection (1) · Server-side request forgery (SSRF) (1) · Arbitrary file upload (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wpjam-basic (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wpjam-basic"><img src="https://laskyr.com/plugins/wpjam-basic/badge.svg" alt="WPJAM Basic vulnerability status"></a>