Plugins · wpify-woo · data as of 2026-11-04
Is WPify Woo safe? Known vulnerabilities and latest version
- Latest version
- 5.5.0
- Last updated
- 2026-10-26
- Active installs
- 5,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 8.1+
WooCommerce features for CZ/SK e-shops: withdrawal & claim, Heureka, CRN/VAT, QR payments, delivery dates, async emails and more. — by WPify
What to do
- Update to the latest version (5.5.0). Anything older than 5.4.17 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wpify-woo --field=version shows what you run; wp plugin update wpify-woo updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 8.0 CVE-2026-12736 · published 2026-07-24
Privilege escalation in WPify Woo (5.4.16 and older)
- Affected
- 5.4.16 and older
- Fixed in
- 5.4.17 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Wpify Woo plugin for WordPress is vulnerable to Privilege Escalation in versions up to, and including, 5.4.16. This is due to the SettingsApi::save_option() REST route (POST /wp-json/wpify-woo/v1/option) passing the request-supplied 'option' and 'data' parameters directly to update_option() without any option-name allowlist or value sanitization, while the permission_callback only verifies the manage_woocommerce capability. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to elevate their privileges to Administrator by overwriting arbitrary WordPress options (for example setting default_role to administrator and users_can_register to 1, or disabling security plugins via active_plugins).
NVD CVE-2026-12736Wordfence advisoryCode change (fix)Plugin source
critical 9.9 CVE-2026-42748 · published 2026-05-27
Arbitrary file upload in WPify Woo (5.4.1 and older)
- Affected
- 5.4.1 and older
- Fixed in
- 5.4.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unrestricted Upload of File with Dangerous Type vulnerability in WPify WPify Woo Czech wpify-woo allows Upload a Web Shell to a Web Server.This issue affects WPify Woo Czech: from n/a through <= 5.4.1.
high 7.1 CVE-2024-33946 · published 2024-05-03
Reflected cross-site scripting (XSS) in WPify Woo (4.0.10 and older)
- Affected
- 4.0.10 and older
- Fixed in
- 4.0.11
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPify s.R.O. WPify Woo Czech allows Reflected XSS.This issue affects WPify Woo Czech: from n/a through 4.0.10.
medium 5.3 CVE-2024-1492 · published 2024-02-29
Missing authorization check in WPify Woo (4.0.8 and older)
- Affected
- 4.0.8 and older
- Fixed in
- 4.0.9 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WPify Woo Czech plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the maybe_send_to_packeta function in all versions up to, and including, 4.0.8. This makes it possible for unauthenticated attackers to obtain shipping details for orders as long as the order number is known.
Recent activity
- 2026-10-26 — latest release on wordpress.org (5.5.0).
- 2026-07-24 — Privilege escalation disclosed (CVE-2026-12736), fixed in 5.4.17.
- 2026-05-27 — Arbitrary file upload disclosed (CVE-2026-42748), fixed in 5.4.2.
- 2024-05-03 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-33946), fixed in 4.0.11.
Get an email when WPify Woo has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WPify Woo (wpify-woo) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Privilege escalation (1) · Arbitrary file upload (1) · Cross-site scripting (XSS) (1) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wpify-woo (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wpify-woo"><img src="https://laskyr.com/plugins/wpify-woo/badge.svg" alt="WPify Woo vulnerability status"></a>