Skip to content
Laskyr

Plugins · wpide · data as of 2026-11-04

Is WPIDE safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.6.2)

As of 2026-11-04. 6 issues are on record for older versions; version 3.5.8 or newer fixes all of them that state a fix.

Latest version
3.6.2
Last updated
2026-10-31
Active installs
40,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4.0+

Manage WordPress files, edit code and add PHP, CSS, JavaScript and HTML snippets from your dashboard. — by XplodedThemes

What to do

  1. Update to the latest version (3.6.2). Anything older than 3.5.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpide --field=version shows what you run; wp plugin update wpide updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-66440 · published 2026-08-06

Cross-site scripting (XSS) in WPIDE (3.5.7 and older)

Affected
3.5.7 and older
Fixed in
3.5.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in WPIDE – File Manager & Code Editor <= 3.5.7 versions.

NVD CVE-2026-66440Patchstack advisory

high 8.8 CVE-2026-57766 · published 2026-07-02

Cross-site request forgery (CSRF) in WPIDE (3.5.6 and older)

Affected
3.5.6 and older
Fixed in
3.5.7 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Request Forgery (CSRF) in WPIDE – File Manager & Code Editor <= 3.5.6 versions.

NVD CVE-2026-57766Patchstack advisory

medium 5.3 CVE-2024-9546 · published 2024-10-15

Information disclosure in WPIDE (3.4.9 and older)

Affected
3.4.9 and older
Fixed in
3.5.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPIDE – File Manager & Code Editor plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 3.4.9. This is due to the plugin utilizing the PHP-Parser library, which outputs parser rebuild command execution results. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.

NVD CVE-2024-9546Wordfence advisoryPlugin source

high 7.2 CVE-2022-40217 · published 2022-09-21

Arbitrary file upload in WPIDE (2.6 and older)

Affected
2.6 and older
Fixed in
3.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authenticated (admin+) Arbitrary File Edit/Upload vulnerability in XplodedThemes WPide plugin <= 2.6 at WordPress.

NVD CVE-2022-40217Patchstack advisorywordpress.org

high 7.2 CVE-2022-2261 · published 2022-08-29

File inclusion in WPIDE (older than 3.0)

Affected
older than 3.0
Fixed in
3.0
Access needed (per CVSS)
Needs an admin-level account
Range from
NVD analysis · score by NVD
Details from the advisory

The WPIDE WordPress plugin before 3.0 does not sanitize and validate the filename parameter before using it in a require statement in the admin dashboard, leading to a Local File Inclusion issue.

NVD CVE-2022-2261WPScan advisory

medium 4.9 CVE-2022-35235 · published 2022-08-23

Path traversal / file read in WPIDE (2.6 and older)

Affected
2.6 and older
Fixed in
3.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authenticated (admin+) Arbitrary File Read vulnerability in XplodedThemes WPide plugin <= 2.6 at WordPress.

NVD CVE-2022-35235Patchstack advisorywordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPIDE vulnerability status badge
<a href="https://laskyr.com/plugins/wpide"><img src="https://laskyr.com/plugins/wpide/badge.svg" alt="WPIDE vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit