Skip to content
Laskyr

Plugins · wpguppy-lite · data as of 2026-11-04

Is One to one user Chat by WPGuppy safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.6)

As of 2026-11-04. 6 issues are on record for older versions; version 1.1.5 or newer fixes all of them that state a fix.

Latest version
1.1.6
Last updated
2026-03-12
Active installs
500+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 8.1+

WPGuppy is a well thought and clinically designed and developed WordPress chat plugin which has been engineered to fulfill the market needs. — by AmentoTech Private Limited

What to do

  1. Update to the latest version (1.1.6). Anything older than 1.1.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpguppy-lite --field=version shows what you run; wp plugin update wpguppy-lite updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-6792 · published 2026-02-14

Missing authorization check in One to one user Chat by WPGuppy (1.1.4 and older)

Affected
1.1.4 and older
Fixed in
1.1.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The One to one user Chat by WPGuppy plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the /wp-json/guppylite/v2/channel-authorize rest endpoint in all versions up to, and including, 1.1.4. This makes it possible for unauthenticated attackers to intercept and view private chat messages between users.

NVD CVE-2025-6792Wordfence advisorywordpress.org

high 8.2 CVE-2025-49910 · published 2025-10-22

Missing authorization check in One to one user Chat by WPGuppy (1.1.4 and older)

Affected
1.1.4 and older
Fixed in
1.1.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in AmentoTech Private Limited WPGuppy wpguppy-lite allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects WPGuppy: from n/a through <= 1.1.4.

NVD CVE-2025-49910Patchstack advisory

high 8.5 CVE-2025-30775 · published 2025-03-27

SQL injection in One to one user Chat by WPGuppy (1.1.3 and older)

Affected
1.1.3 and older
Fixed in
1.1.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in AmentoTech Private Limited WPGuppy wpguppy-lite allows SQL Injection.This issue affects WPGuppy: from n/a through <= 1.1.3.

NVD CVE-2025-30775Patchstack advisory

medium 6.5 CVE-2025-24643 · published 2025-02-03

Missing authorization check in One to one user Chat by WPGuppy (1.1.0 and older)

Affected
1.1.0 and older
Fixed in
1.1.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in AmentoTech Private Limited WPGuppy wpguppy-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WPGuppy: from n/a through <= 1.1.0.

NVD CVE-2025-24643Patchstack advisory

high 8.8 CVE-2024-56280 · published 2025-01-07

Privilege escalation in One to one user Chat by WPGuppy (1.1.0 and older)

Affected
1.1.0 and older
Fixed in
1.1.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Incorrect Privilege Assignment vulnerability in AmentoTech Private Limited WPGuppy wpguppy-lite allows Privilege Escalation.This issue affects WPGuppy: from n/a through <= 1.1.0.

NVD CVE-2024-56280Patchstack advisory

critical 9.8 CVE-2024-49222 · published 2025-01-07

PHP object injection in One to one user Chat by WPGuppy (1.1.0 and older)

Affected
1.1.0 and older
Fixed in
1.1.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in AmentoTech Private Limited WPGuppy wpguppy-lite allows Object Injection.This issue affects WPGuppy: from n/a through <= 1.1.0.

NVD CVE-2024-49222Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
One to one user Chat by WPGuppy vulnerability status badge
<a href="https://laskyr.com/plugins/wpguppy-lite"><img src="https://laskyr.com/plugins/wpguppy-lite/badge.svg" alt="One to one user Chat by WPGuppy vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit