Plugins · wpgsi · data as of 2026-11-04
Is WPGSI safe? Known vulnerabilities and latest version
- Latest version
- 3.8.4
- Last updated
- 2026-02-14
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
Google sheet two-way sync 🔄 WordPress | WooCommerce | Contact form 7 | DB table | Google sheet as a Table. — by javmah
What to do
- Update to the latest version (3.8.4). Anything older than 3.8.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wpgsi --field=version shows what you run; wp plugin update wpgsi updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-1916 · published 2026-02-25
Missing authorization check in WPGSI (3.8.3 and older)
- Affected
- 3.8.3 and older
- Fixed in
- 3.8.4 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WPGSI: Spreadsheet Integration plugin for WordPress is vulnerable to unauthorized modification and loss of data due to missing capability checks and an insecure authentication mechanism on the `wpgsi_callBackFuncAccept` and `wpgsi_callBackFuncUpdate` REST API functions in all versions up to, and including, 3.8.3. Both REST endpoints use `permission_callback => '__return_true'`, allowing unauthenticated access. The plugin's custom token-based validation relies on a Base64-encoded JSON object containing the user ID and email address, but is not cryptographically signed. This makes it possible for unauthenticated attackers to forge tokens using publicly enumerable information (admin user ID and email) to create, modify, and delete arbitrary WordPress posts and pages, granted they know the administrator's email address and an active integration ID with remote updates enabled.
NVD CVE-2026-1916Wordfence advisoryCode change (fix)Plugin source
medium 4.3 CVE-2025-1463 · published 2025-03-05
Cross-site request forgery (CSRF) in WPGSI (3.8.2 and older)
- Affected
- 3.8.2 and older
- Fixed in
- 3.8.3 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Spreadsheet Integration plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.8.2. This is due to improper nonce validation within the class-wpgsi-show.php script. This makes it possible for unauthenticated attackers to publish arbitrary posts, including private, granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2025-1463Wordfence advisoryCode change (fix)wordpress.orgPlugin source
medium 4.3 CVE-2024-6590 · published 2024-09-25
Missing authorization check in WPGSI (3.8.0 and older)
- Affected
- 3.8.0 and older
- Fixed in
- 3.8.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Spreadsheet Integration – Automate Google Sheets With WordPress, WooCommerce & Most Popular Form Plugins. Also, Display Google sheet as a Table. plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on several functions in all versions up to, and including, 3.8.0. This makes it possible for authenticated attackers, with Subscriber-level access and above, to edit post status, edit Google sheet integrations, and create Google sheet integrations.
Recent activity
- 2026-02-14 — latest release on wordpress.org (3.8.4).
- 2026-02-25 — Missing authorization check disclosed (CVE-2026-1916), fixed in 3.8.4.
- 2025-03-05 — Cross-site request forgery (CSRF) disclosed (CVE-2025-1463), fixed in 3.8.3.
- 2024-09-25 — Missing authorization check disclosed (CVE-2024-6590), fixed in 3.8.1.
Get an email when WPGSI has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WPGSI (wpgsi) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Missing authorization (2) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wpgsi (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wpgsi"><img src="https://laskyr.com/plugins/wpgsi/badge.svg" alt="WPGSI vulnerability status"></a>