Skip to content
Laskyr

Plugins · wpfront-notification-bar · data as of 2026-11-04

Is WPFront Notification Bar safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.5.2)

As of 2026-11-04. 5 issues are on record for older versions; version 3.5.2 or newer fixes all of them that state a fix.

Latest version
3.5.2
Last updated
2026-09-29
Active installs
40,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Easily lets you create a bar on top or bottom to display a notification. — by Syam Mohan

What to do

  1. Update to the latest version (3.5.2). Anything older than 3.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpfront-notification-bar --field=version shows what you run; wp plugin update wpfront-notification-bar updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-93896 · published 2026-10-03

Reflected cross-site scripting (XSS) in WPFront Notification Bar (3.5.1 and older)

Affected
3.5.1 and older
Fixed in
3.5.2 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPFront Notification Bar plugin for WordPress is vulnerable to Reflected Cross-Site Scripting in versions up to, and including, 3.5.1. This is due to the debug-log output path (write_debug_logs) reflecting the raw value of $_SERVER['REQUEST_URI'] through vprintf() directly inside a <script> block emitted on wp_footer, without any sanitization or escaping (see the 'Current URL is "%s"' log entry produced by the URL-text display filter in the filter() method). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a specially crafted link.

NVD CVE-2026-93896Wordfence advisoryCode change (fix)Plugin source

medium 5.9 CVE-2024-29819 · published 2024-03-27

Stored cross-site scripting (XSS) in WPFront Notification Bar (3.3.2 and older)

Affected
3.3.2 and older
Fixed in
3.4
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Syam Mohan WPFront Notification Bar allows Stored XSS.This issue affects WPFront Notification Bar: from n/a through 3.3.2.

NVD CVE-2024-29819Patchstack advisory

medium 4.8 CVE-2024-0625 · published 2024-01-25

Stored cross-site scripting (XSS) in WPFront Notification Bar (3.3.2 and older)

Affected
3.3.2 and older
Fixed in
3.4 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WPFront Notification Bar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘wpfront-notification-bar-options[custom_class]’ parameter in all versions up to, and including, 3.3.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2024-0625Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2021-24601 · published 2021-09-06

Cross-site scripting (XSS) in WPFront Notification Bar (older than 2.1.0)

Affected
older than 2.1.0
Fixed in
2.1.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The WPFront Notification Bar WordPress plugin before 2.1.0.08087 does not properly sanitise and escape its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.

NVD CVE-2021-24601WPScan advisory

medium 4.8 CVE-2021-24518 · published 2021-08-16

Stored cross-site scripting (XSS) in WPFront Notification Bar (older than 2.0.0.07176)

Affected
older than 2.0.0.07176
Fixed in
2.0.0.07176
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD
Details from the advisory

The WPFront Notification Bar WordPress plugin before 2.0.0.07176 does not sanitise or escape its Custom CSS setting, allowing high privilege users such as admin to set XSS payload in it even when the unfiltered_html capability is disallowed, leading to an authenticated Stored Cross-Site Scripting issue

NVD CVE-2021-24518WPScan advisorypacketstormsecurity.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPFront Notification Bar vulnerability status badge
<a href="https://laskyr.com/plugins/wpfront-notification-bar"><img src="https://laskyr.com/plugins/wpfront-notification-bar/badge.svg" alt="WPFront Notification Bar vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit