Skip to content
Laskyr

Plugins · wpecounter · data as of 2026-11-04

Is WP Views Counter safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.1.3)

As of 2026-11-04. 2 issues are on record for older versions; version 2.1.3 or newer fixes all of them that state a fix.

Latest version
2.1.3
Last updated
2025-12-19
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.0+

Fast, lightweight post views counter. Display views in admin, blocks or shortcodes — no tracking scripts required. — by etruel

What to do

  1. Update to the latest version (2.1.3). Anything older than 2.1.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpecounter --field=version shows what you run; wp plugin update wpecounter updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2025-66130 · published 2025-12-16

Missing authorization check in WP Views Counter (2.1.2 and older)

Affected
2.1.2 and older
Fixed in
2.1.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in etruel WP Views Counter wpecounter allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Views Counter: from n/a through <= 2.1.2.

NVD CVE-2025-66130Patchstack advisory

medium 6.5 CVE-2025-49859 · published 2025-06-17

Stored cross-site scripting (XSS) in WP Views Counter (2.0.3 and older)

Affected
2.0.3 and older
Fixed in
2.0.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in etruel WP Views Counter wpecounter allows Stored XSS.This issue affects WP Views Counter: from n/a through <= 2.0.3.

NVD CVE-2025-49859Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Views Counter vulnerability status badge
<a href="https://laskyr.com/plugins/wpecounter"><img src="https://laskyr.com/plugins/wpecounter/badge.svg" alt="WP Views Counter vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit