Skip to content
Laskyr

Plugins · wpconsent-cookies-banner-privacy-suite · data as of 2026-11-04

Is WPConsent safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.0)

As of 2026-11-04. 1 issue is on record for older versions; version 1.2.0 or newer fixes all of them that state a fix.

Latest version
1.2.0
Last updated
2026-10-08
Active installs
200,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

Cookie consent banner with cookie scanner & script blocking. Manage cookie consent, cookie notice & cookie policy for GDPR, CCPA & privacy compliance. — by Syed Balkhi

What to do

  1. Update to the latest version (1.2.0). Anything older than 1.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpconsent-cookies-banner-privacy-suite --field=version shows what you run; wp plugin update wpconsent-cookies-banner-privacy-suite updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-97640 · published 2026-10-16

Stored cross-site scripting (XSS) in WPConsent (1.1.9 and older)

Affected
1.1.9 and older
Fixed in
1.2.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPConsent – Cookie Banner & Cookie Consent for Privacy Compliance (GDPR / CCPA / EU Compliance Cookie Notice) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content via Simple HTML DOM Parser Noise-Key Restoration (mXSS) in all versions up to, and including, 1.1.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the Script Blocking feature to be enabled, and the exploit chain depends on an attacker submitting two coordinated comments — one embedding event-handler syntax inside an allowed <code> element and one placing the deterministic ___noise___ restoration key inside an allowed <abbr title=""> attribute — with the key offset confirmable via an unauthenticated wpconsent_debug=1 request.

NVD CVE-2026-97640Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPConsent vulnerability status badge
<a href="https://laskyr.com/plugins/wpconsent-cookies-banner-privacy-suite"><img src="https://laskyr.com/plugins/wpconsent-cookies-banner-privacy-suite/badge.svg" alt="WPConsent vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit