Skip to content
Laskyr

Plugins · wpcomplete · data as of 2026-11-04

Is WPComplete safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.9.5.8)

As of 2026-11-04. 9 issues are on record for older versions; version 2.9.5.7 or newer fixes all of them that state a fix.

Latest version
2.9.5.8
Last updated
2026-10-07
Active installs
1,000+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4

A WordPress plugin that helps your students keep track of their progress through your course. — by Nexcess

What to do

  1. Update to the latest version (2.9.5.8). Anything older than 2.9.5.7 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpcomplete --field=version shows what you run; wp plugin update wpcomplete updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 1 record(s) do not state which versions are affected.

high 7.1 CVE-2026-66479 · published 2026-10-08

Cross-site request forgery (CSRF) in WPComplete (2.9.5.6 and older)

Affected
2.9.5.6 and older
Fixed in
2.9.5.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Liquid Web / StellarWP WPComplete wpcomplete allows Stored XSS.This issue affects WPComplete: from n/a through 2.9.5.6.

NVD CVE-2026-66479Patchstack advisory

medium 6.4 CVE-2026-77820 · published 2026-09-19

Stored cross-site scripting (XSS) in WPComplete (2.9.9.0 and older)

Affected
2.9.9.0 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence

Note: the source's version range goes past the newest WPComplete release on wordpress.org (2.9.5.8), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

The WPComplete plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'empty' Shortcode Attribute in all versions up to, and including, 2.9.9.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the premium version of the software in order to exploit. Please note this only affects the pro version.

NVD CVE-2026-77820Wordfence advisoryPlugin source

high 7.1 CVE-2026-66599 · published 2026-08-24

Cross-site scripting (XSS) in WPComplete (2.9.5.6 and older)

Affected
2.9.5.6 and older
Fixed in
2.9.5.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in WPComplete <= 2.9.5.6 versions.

NVD CVE-2026-66599Patchstack advisory

medium 5.4 CVE-2026-57661 · published 2026-06-26

Missing authorization check in WPComplete (2.9.5.5 and older)

Affected
2.9.5.5 and older
Fixed in
2.9.5.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in WPComplete <= 2.9.5.5 versions.

NVD CVE-2026-57661Patchstack advisory

medium 6.5 CVE-2026-42750 · published 2026-05-27

Stored cross-site scripting (XSS) in WPComplete (2.9.5.4 and older)

Affected
2.9.5.4 and older
Fixed in
2.9.5.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nexcess WPComplete wpcomplete allows Stored XSS.This issue affects WPComplete: from n/a through <= 2.9.5.4.

NVD CVE-2026-42750Patchstack advisory

medium 5.3 CVE-2025-49906 · published 2025-10-22

Missing authorization check in WPComplete (2.9.5.3 and older)

Affected
2.9.5.3 and older
Fixed in
2.9.5.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in StellarWP WPComplete wpcomplete allows Accessing Functionality Not Properly Constrained by ACLs.This issue affects WPComplete: from n/a through <= 2.9.5.3.

NVD CVE-2025-49906Patchstack advisory

medium 6.5 CVE-2025-58974 · published 2025-09-22

Stored cross-site scripting (XSS) in WPComplete (2.9.5.2 and older)

Affected
2.9.5.2 and older
Fixed in
2.9.5.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in StellarWP WPComplete wpcomplete allows Stored XSS.This issue affects WPComplete: from n/a through <= 2.9.5.2.

NVD CVE-2025-58974Patchstack advisory

medium 6.5 CVE-2025-50046 · published 2025-06-20

Stored cross-site scripting (XSS) in WPComplete (2.9.5 and older)

Affected
2.9.5 and older
Fixed in
2.9.5.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in StellarWP WPComplete wpcomplete allows Stored XSS.This issue affects WPComplete: from n/a through <= 2.9.5.

NVD CVE-2025-50046Patchstack advisory

medium 6.1 CVE-2022-45825 · published 2023-03-28

Reflected cross-site scripting (XSS) in WPComplete (2.9.4 and older)

Affected
2.9.4 and older
Fixed in
2.9.5
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in iThemes WPComplete plugin <= 2.9.2 versions.

NVD CVE-2022-45825Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPComplete vulnerability status badge
<a href="https://laskyr.com/plugins/wpcomplete"><img src="https://laskyr.com/plugins/wpcomplete/badge.svg" alt="WPComplete vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit