Skip to content
Laskyr

Plugins · wpcal · data as of 2026-11-04

Is WPCal.io safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (0.9.5.10)

As of 2026-11-04. 3 issues are on record for older versions; version 0.9.5.10 or newer fixes all of them that state a fix.

Latest version
0.9.5.10
Last updated
2025-11-18
Active installs
800+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.4.14 · PHP 7.1+

Your clients can quickly view your real-time availability and self-book their own slots, and eliminate all back-and-forth emailing. — by revmakx

What to do

  1. Update to the latest version (0.9.5.10). Anything older than 0.9.5.10 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpcal --field=version shows what you run; wp plugin update wpcal updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-66103 · published 2025-12-30

Cross-site scripting (XSS) in WPCal.io (0.9.5.9 and older)

Affected
0.9.5.9 and older
Fixed in
0.9.5.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in revmakx WPCal.io wpcal allows DOM-Based XSS.This issue affects WPCal.io: from n/a through <= 0.9.5.9.

NVD CVE-2025-66103Patchstack advisory

medium 5.4 CVE-2024-34816 · published 2024-05-14

Cross-site request forgery (CSRF) in WPCal.io (0.9.5.8 and older)

Affected
0.9.5.8 and older
Fixed in
0.9.5.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Revmakx WPCal.Io – Easy Meeting Scheduler.This issue affects WPCal.Io – Easy Meeting Scheduler: from n/a through 0.9.5.8.

NVD CVE-2024-34816Patchstack advisory

medium 4.3 CVE-2024-32795 · published 2024-04-24

Cross-site request forgery (CSRF) in WPCal.io (0.9.5.8 and older)

Affected
0.9.5.8 and older
Fixed in
0.9.5.9
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Revmakx WPCal.Io – Easy Meeting Scheduler.This issue affects WPCal.Io – Easy Meeting Scheduler: from n/a through 0.9.5.8.

NVD CVE-2024-32795Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPCal.io vulnerability status badge
<a href="https://laskyr.com/plugins/wpcal"><img src="https://laskyr.com/plugins/wpcal/badge.svg" alt="WPCal.io vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit