Skip to content
Laskyr

Plugins · wpc-smart-messages · data as of 2026-11-04

Is WPC Smart Messages for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.3.5)

As of 2026-11-04. 4 issues are on record for older versions; version 4.2.9 or newer fixes all of them that state a fix.

Latest version
4.3.5
Last updated
2026-10-17
Active installs
1,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

WPC Smart Messages help you display messages throughout your store through smart conditional logic settings. — by WPClever

What to do

  1. Update to the latest version (4.3.5). Anything older than 4.2.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpc-smart-messages --field=version shows what you run; wp plugin update wpc-smart-messages updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-6725 · published 2026-04-28

Stored cross-site scripting (XSS) in WPC Smart Messages for WooCommerce (4.2.8 and older)

Affected
4.2.8 and older
Fixed in
4.2.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPC Smart Messages for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'text' attribute of the `wpcsm_text_rotator` shortcode in all versions up to, and including, 4.2.8. This is due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-6725Wordfence advisorywordpress.orgPlugin source

medium 6.5 CVE-2025-62903 · published 2025-10-27

Stored cross-site scripting (XSS) in WPC Smart Messages for WooCommerce (4.2.8 and older)

Affected
4.2.8 and older
Fixed in
4.2.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPClever WPC Smart Messages for WooCommerce wpc-smart-messages allows Stored XSS.This issue affects WPC Smart Messages for WooCommerce: from n/a through <= 4.2.8.

NVD CVE-2025-62903Patchstack advisory

medium 4.3 CVE-2024-10437 · published 2024-10-29

Missing authorization check in WPC Smart Messages for WooCommerce (4.2.1 and older)

Affected
4.2.1 and older
Fixed in
4.2.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPC Smart Messages for WooCommerce plugin for WordPress is vulnerable to unauthorized Smar Message activation/deactivation due to a missing capability check on the ajax_enable function in all versions up to, and including, 4.2.1. This makes it possible for authenticated attackers, with Subscriber-level access and above, to activate or deactivate smart messages.

NVD CVE-2024-10437Wordfence advisoryCode change (fix)Plugin source

high 8.8 CVE-2024-10436 · published 2024-10-29

File inclusion in WPC Smart Messages for WooCommerce (4.2.1 and older)

Affected
4.2.1 and older
Fixed in
4.2.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WPC Smart Messages for WooCommerce plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 4.2.1 via the get_condition_value function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.

NVD CVE-2024-10436Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPC Smart Messages for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/wpc-smart-messages"><img src="https://laskyr.com/plugins/wpc-smart-messages/badge.svg" alt="WPC Smart Messages for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit