Plugins · wpc-product-options · data as of 2026-11-04
Is WPC Product Options for WooCommerce safe? Known vulnerabilities and latest version
- Latest version
- 4.0.8
- Last updated
- 2026-11-03
- Active installs
- 4,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
WPC Product Options brings about the power of adjusting prices with highly customizable additional fields for products. — by WPClever
What to do
- Update to the latest version (4.0.8). Anything older than 4.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wpc-product-options --field=version shows what you run; wp plugin update wpc-product-options updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-97660 · published 2026-10-03
Stored cross-site scripting (XSS) in WPC Product Options for WooCommerce (4.0.5 and older)
- Affected
- 4.0.5 and older
- Fixed in
- 4.0.6 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WPC Product Options for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via wpcpo-* Array Key via Multipart Field Name in all versions up to, and including, 4.0.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is exploitable via guest checkout without authentication because the malicious payload is embedded in a multipart Content-Disposition field name beginning with 'wpcpo-', which PHP's RFC1867 parser preserves byte-for-byte and stores into order item meta.
NVD CVE-2026-97660Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2026-49061 · published 2026-06-15
Path traversal / file read in WPC Product Options for WooCommerce (3.2.1 and older)
- Affected
- 3.2.1 and older
- Fixed in
- 3.2.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Arbitrary File Download in WPC Product Options for WooCommerce <= 3.2.1 versions.
high 7.5 CVE-2025-60248 · published 2025-11-06
File inclusion in WPC Product Options for WooCommerce (3.1.3 and older)
- Affected
- 3.1.3 and older
- Fixed in
- 3.1.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in WPClever WPC Product Options for WooCommerce wpc-product-options allows PHP Local File Inclusion.This issue affects WPC Product Options for WooCommerce: from n/a through <= 3.1.3.
Recent activity
- 2026-11-03 — latest release on wordpress.org (4.0.8).
- 2026-10-03 — Stored cross-site scripting (XSS) disclosed (CVE-2026-97660), fixed in 4.0.6.
- 2026-06-15 — Path traversal / file read disclosed (CVE-2026-49061), fixed in 3.2.2.
- 2025-11-06 — File inclusion disclosed (CVE-2025-60248), fixed in 3.1.3.
Get an email when WPC Product Options for WooCommerce has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WPC Product Options for WooCommerce (wpc-product-options) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WPClever (8 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Path traversal and file read (1) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wpc-product-options (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wpc-product-options"><img src="https://laskyr.com/plugins/wpc-product-options/badge.svg" alt="WPC Product Options for WooCommerce vulnerability status"></a>