Skip to content
Laskyr

Plugins · wpbulky-wp-bulk-edit-post-types · data as of 2026-11-04

Is WPBulky safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.3)

As of 2026-11-04. 3 issues are on record for older versions; version 1.2.3 or newer fixes all of them that state a fix.

Latest version
1.2.3
Last updated
2026-08-27
Active installs
400+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

A helpful tool that allows you to bulk edit post types (posts, pages, media, comments...) — by VillaTheme

What to do

  1. Update to the latest version (1.2.3). Anything older than 1.2.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wpbulky-wp-bulk-edit-post-types --field=version shows what you run; wp plugin update wpbulky-wp-bulk-edit-post-types updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.5 CVE-2026-82227 · published 2026-08-28

SQL injection in WPBulky (1.2.2 and older)

Affected
1.2.2 and older
Fixed in
1.2.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor SQL Injection in WPBulky <= 1.2.2 versions.

NVD CVE-2026-82227Patchstack advisory

high 7.6 CVE-2025-68550 · published 2025-12-23

SQL injection in WPBulky (1.1.13 and older)

Affected
1.1.13 and older
Fixed in
1.1.14
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in VillaTheme WPBulky wpbulky-wp-bulk-edit-post-types allows Blind SQL Injection.This issue affects WPBulky: from n/a through <= 1.1.13.

NVD CVE-2025-68550Patchstack advisory

medium 5.4 CVE-2023-30482 · published 2023-08-08

Stored cross-site scripting (XSS) in WPBulky (older than 1.0.10)

Affected
older than 1.0.10
Fixed in
1.0.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in VillaTheme WPBulky plugin <= 1.0.10 versions.

NVD CVE-2023-30482Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WPBulky vulnerability status badge
<a href="https://laskyr.com/plugins/wpbulky-wp-bulk-edit-post-types"><img src="https://laskyr.com/plugins/wpbulky-wp-bulk-edit-post-types/badge.svg" alt="WPBulky vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit