Skip to content
Laskyr

Plugins · wp2leads · data as of 2026-11-04

Is WP2LEADS safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.5.18)

As of 2026-11-04. 9 issues are on record for older versions; version 3.5.12 or newer fixes all of them that state a fix.

Latest version
3.5.18
Last updated
2026-11-02
Active installs
70+
Known issues on record
9
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Wie du deine Lieblings-Plugins wie WooCommerce, WebinarIgnition, Contact Form 7, Learndash usw. mit dem E-Mail-Marketing-Service KlickTipp verbindest. — by Tobias @Saleswonder.biz

What to do

  1. Update to the latest version (3.5.18). Anything older than 3.5.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp2leads --field=version shows what you run; wp plugin update wp2leads updates it.

Check your version

Known vulnerabilities

9 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-9462 · published 2026-10-31

SQL injection in WP2LEADS (3.5.6 and older)

Affected
3.5.6 and older
Fixed in
3.5.12 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP2LEADS plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order’ parameter in all versions up to, and including, 3.5.6 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2025-9462Wordfence advisoryCode change (fix)wordpress.orgPlugin source

high 7.1 CVE-2026-25433 · published 2026-10-06

Missing authorization check in WP2LEADS (3.5.7 and older)

Affected
3.5.7 and older
Fixed in
3.5.12 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in WP2LEADS <= 3.5.7 versions.

NVD CVE-2026-25433Patchstack advisory

high 8.5 CVE-2026-25434 · published 2026-10-06

SQL injection in WP2LEADS (3.5.7 and older)

Affected
3.5.7 and older
Fixed in
3.5.12 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber SQL Injection in WP2LEADS <= 3.5.7 versions.

NVD CVE-2026-25434Patchstack advisory

high 7.1 CVE-2025-49316 · published 2025-06-17

Reflected cross-site scripting (XSS) in WP2LEADS (3.5.0 and older)

Affected
3.5.0 and older
Fixed in
3.5.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Saleswonder Team: Tobias WP2LEADS wp2leads allows Reflected XSS.This issue affects WP2LEADS: from n/a through <= 3.5.0.

NVD CVE-2025-49316Patchstack advisory

high 7.1 CVE-2025-32922 · published 2025-05-15

Cross-site request forgery (CSRF) in WP2LEADS (3.5.0 and older)

Affected
3.5.0 and older
Fixed in
3.5.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Saleswonder Team: Tobias WP2LEADS wp2leads allows Stored XSS.This issue affects WP2LEADS: from n/a through <= 3.5.0.

NVD CVE-2025-32922Patchstack advisory

high 7.1 CVE-2025-30827 · published 2025-04-01

Reflected cross-site scripting (XSS) in WP2LEADS (3.4.5 and older)

Affected
3.4.5 and older
Fixed in
3.4.7
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Saleswonder Team: Tobias WP2LEADS wp2leads allows Reflected XSS.This issue affects WP2LEADS: from n/a through <= 3.4.5.

NVD CVE-2025-30827Patchstack advisory

high 7.1 CVE-2025-24565 · published 2025-02-14

Reflected cross-site scripting (XSS) in WP2LEADS (3.3.3 and older)

Affected
3.3.3 and older
Fixed in
3.3.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Saleswonder Team: Tobias WP2LEADS wp2leads allows Reflected XSS.This issue affects WP2LEADS: from n/a through <= 3.3.3.

NVD CVE-2025-24565Patchstack advisory

high 7.1 CVE-2024-56065 · published 2025-01-13

Reflected cross-site scripting (XSS) in WP2LEADS (3.4.2 and older)

Affected
3.4.2 and older
Fixed in
3.4.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Saleswonder Team: Tobias WP2LEADS wp2leads allows Reflected XSS.This issue affects WP2LEADS: from n/a through <= 3.4.2.

NVD CVE-2024-56065Patchstack advisory

medium 5.4 CVE-2024-31375 · published 2024-04-08

Missing authorization check in WP2LEADS (3.2.7 and older)

Affected
3.2.7 and older
Fixed in
3.2.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Saleswonder Team: Tobias WP2LEADS wp2leads.This issue affects WP2LEADS: from n/a through <= 3.2.7.

NVD CVE-2024-31375Patchstack advisoryPatchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP2LEADS vulnerability status badge
<a href="https://laskyr.com/plugins/wp2leads"><img src="https://laskyr.com/plugins/wp2leads/badge.svg" alt="WP2LEADS vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit