Plugins · wp-youtube-lyte · data as of 2026-11-04
Is WP YouTube Lyte safe? Known vulnerabilities and latest version
- Latest version
- 1.7.32
- Last updated
- 2026-08-20
- Active installs
- 20,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
High performance YouTube video, playlist and audio-only embeds which don't slow down your blog and offer optimal accessibility. — by Frank Goossens
What to do
- Update to the latest version (1.7.32). Anything older than 1.7.31 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-youtube-lyte --field=version shows what you run; wp plugin update wp-youtube-lyte updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.8 CVE-2026-96895 · published 2026-09-27
Stored cross-site scripting (XSS) in WP YouTube Lyte (older than 1.7.31)
- Affected
- older than 1.7.31
- Fixed in
- 1.7.31
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The WP YouTube Lyte WordPress plugin before 1.7.31 does not escape some attributes of YouTube embed blocks before outputting them in an HTML attribute when rendering the block, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks.
medium 6.4 CVE-2026-3299 · published 2026-04-16
Stored cross-site scripting (XSS) in WP YouTube Lyte (1.7.29 and older)
- Affected
- 1.7.29 and older
- Fixed in
- 1.7.30 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP YouTube Lyte plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'lyte' shortcode in all versions up to, and including, 1.7.29 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
low 3.4 CVE-2025-66062 · published 2025-11-21
Open redirect in WP YouTube Lyte (1.7.28 and older)
- Affected
- 1.7.28 and older
- Fixed in
- 1.7.29
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Frank Goossens WP YouTube Lyte wp-youtube-lyte allows Phishing.This issue affects WP YouTube Lyte: from n/a through <= 1.7.28.
medium 4.8 CVE-2021-24419 · published 2021-07-12
Stored cross-site scripting (XSS) in WP YouTube Lyte (older than 1.7.16)
- Affected
- older than 1.7.16
- Fixed in
- 1.7.16
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
The WP YouTube Lyte WordPress plugin before 1.7.16 did not sanitise or escape its lyte_yt_api_key and lyte_notification settings before outputting them back in the page, allowing high privilege users to set XSS payload on them and leading to stored Cross-Site Scripting issues.
Recent activity
- 2026-08-20 — latest release on wordpress.org (1.7.32).
- 2026-09-27 — Stored cross-site scripting (XSS) disclosed (CVE-2026-96895), fixed in 1.7.31.
- 2026-04-16 — Stored cross-site scripting (XSS) disclosed (CVE-2026-3299), fixed in 1.7.30.
- 2025-11-21 — Open redirect disclosed (CVE-2025-66062), fixed in 1.7.29.
Get an email when WP YouTube Lyte has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP YouTube Lyte (wp-youtube-lyte) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3) · Open redirect (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-youtube-lyte (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-youtube-lyte"><img src="https://laskyr.com/plugins/wp-youtube-lyte/badge.svg" alt="WP YouTube Lyte vulnerability status"></a>