Skip to content
Laskyr

Plugins · wp-whatsapp-chat · data as of 2026-11-04

Is Social Chat safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (8.7.0)

As of 2026-11-04. 1 issue is on record for older versions; version 8.6.3 or newer fixes all of them that state a fix.

Latest version
8.7.0
Last updated
2026-10-22
Active installs
200,000+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

WhatsApp Chat🔥 allows you to enhance customer engagement! Integrate "WhatsApp" or "WhatsApp Business" with a single click. — by quadlayers

What to do

  1. Update to the latest version (8.7.0). Anything older than 8.6.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-whatsapp-chat --field=version shows what you run; wp plugin update wp-whatsapp-chat updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-18404 · published 2026-09-05

Stored cross-site scripting (XSS) in Social Chat (8.6.2 and older)

Affected
8.6.2 and older
Fixed in
8.6.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Social Chat – Click To Chat App Button plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'consent_message' JSON Attribute in .qlwapp data-box in all versions up to, and including, 8.6.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit requires no user interaction beyond page load, as setting auto_open and consent_enabled to 'yes' in the injected data-box JSON causes the consent box — and the embedded script — to execute immediately on page load.

NVD CVE-2026-18404Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Social Chat vulnerability status badge
<a href="https://laskyr.com/plugins/wp-whatsapp-chat"><img src="https://laskyr.com/plugins/wp-whatsapp-chat/badge.svg" alt="Social Chat vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit