Skip to content
Laskyr

Plugins · wp-webhooks · data as of 2026-11-04

Is WP Webhooks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.5.0)

As of 2026-11-04. 3 issues are on record for older versions; version 3.3.9 or newer fixes all of them that state a fix.

Latest version
3.5.0
Last updated
2026-10-08
Active installs
20,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4

Automate everything & connect your website, plugins and services together with no-code automations. Browse 100+ integrations... — by Cozmoslabs

What to do

  1. Update to the latest version (3.5.0). Anything older than 3.3.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-webhooks --field=version shows what you run; wp plugin update wp-webhooks updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.0 CVE-2025-66074 · published 2025-12-18

Arbitrary file upload in WP Webhooks (3.3.8 and older)

Affected
3.3.8 and older
Fixed in
3.3.9
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in Cozmoslabs WP Webhooks wp-webhooks allows Path Traversal.This issue affects WP Webhooks: from n/a through <= 3.3.8.

NVD CVE-2025-66074Patchstack advisory

high 7.2 CVE-2025-66073 · published 2025-11-21

PHP object injection in WP Webhooks (3.3.8 and older)

Affected
3.3.8 and older
Fixed in
3.3.9
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Cozmoslabs WP Webhooks wp-webhooks allows Object Injection.This issue affects WP Webhooks: from n/a through <= 3.3.8.

NVD CVE-2025-66073Patchstack advisory

critical 9.8 CVE-2025-8895 · published 2025-08-21

Path traversal / file read in WP Webhooks (3.3.5 and older)

Affected
3.3.5 and older
Fixed in
3.3.6 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Webhooks plugin for WordPress is vulnerable to arbitrary file copy due to missing validation of user-supplied input in all versions up to, and including, 3.3.5. This makes it possible for unauthenticated attackers to copy arbitrary files on the affected site's server to arbitrary locations. This can be used to copy the contents of wp-config.php into a text file which can then be accessed in a browser to reveal database credentials.

NVD CVE-2025-8895Wordfence advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Webhooks vulnerability status badge
<a href="https://laskyr.com/plugins/wp-webhooks"><img src="https://laskyr.com/plugins/wp-webhooks/badge.svg" alt="WP Webhooks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit