Skip to content
Laskyr

Plugins · wp-webauthn · data as of 2026-11-04

Is WP-WebAuthn safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.4.1)

As of 2026-11-04. 3 issues are on record for older versions; version 1.4.0 or newer fixes all of them that state a fix.

Latest version
1.4.1
Last updated
2026-04-15
Active installs
2,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

WP-WebAuthn enables passwordless login through FIDO2 and U2F devices like Passkey, FaceID or Windows Hello for your site. — by Axton

What to do

  1. Update to the latest version (1.4.1). Anything older than 1.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-webauthn --field=version shows what you run; wp plugin update wp-webauthn updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2025-13910 · published 2026-03-21

Stored cross-site scripting (XSS) in WP-WebAuthn (1.3.4 and older)

Affected
1.3.4 and older
Fixed in
1.4.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP-WebAuthn plugin for WordPress is vulnerable to Unauthenticated Stored Cross-Site Scripting via the `wwa_auth` AJAX endpoint in all versions up to, and including, 1.3.4 due to insufficient input sanitization and output escaping on user supplied attributes logged by the plugin. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses the plugin's log page, provided that the logging option is enabled in the plugin settings.

NVD CVE-2025-13910Wordfence advisoryPlugin source

medium 6.5 CVE-2024-47650 · published 2024-10-06

Stored cross-site scripting (XSS) in WP-WebAuthn (1.3.1 and older)

Affected
1.3.1 and older
Fixed in
1.3.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Axton WP-WebAuthn wp-webauthn allows Stored XSS.This issue affects WP-WebAuthn: from n/a through <= 1.3.1.

NVD CVE-2024-47650Patchstack advisory

medium 5.4 CVE-2024-9023 · published 2024-09-28

Stored cross-site scripting (XSS) in WP-WebAuthn (1.3.3 and older)

Affected
1.3.3 and older
Fixed in
1.3.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP-WebAuthn plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's wwa_login_form shortcode in all versions up to, and including, 1.3.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-9023Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP-WebAuthn vulnerability status badge
<a href="https://laskyr.com/plugins/wp-webauthn"><img src="https://laskyr.com/plugins/wp-webauthn/badge.svg" alt="WP-WebAuthn vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit