Plugins · wp-w3all-phpbb-integration · data as of 2026-11-04
Is WP w3all phpBB safe? Known vulnerabilities and latest version
- Latest version
- 3.2.0
- Last updated
- 2026-11-03
- Active installs
- 200+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.2+
w3all WP phpBB integration - easy, light. — by axew3
What to do
- Update to the latest version (3.2.0). Anything older than 3.1.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-w3all-phpbb-integration --field=version shows what you run; wp plugin update wp-w3all-phpbb-integration updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-107422 · published 2026-10-14
Stored cross-site scripting (XSS) in WP w3all phpBB (3.1.0 and older)
- Affected
- 3.1.0 and older
- Fixed in
- 3.1.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in axew3.com WP w3all phpBB wp-w3all-phpbb-integration allows Stored XSS.This issue affects WP w3all phpBB: from n/a through 3.1.0.
high 7.1 CVE-2026-78293 · published 2026-08-27
Cross-site scripting (XSS) in WP w3all phpBB (3.0.6 and older)
- Affected
- 3.0.6 and older
- Fixed in
- 3.0.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in WP w3all phpBB <= 3.0.6 versions.
high 8.5 CVE-2026-73998 · published 2026-08-20
SQL injection in WP w3all phpBB (3.0.5 and older)
- Affected
- 3.0.5 and older
- Fixed in
- 3.0.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Subscriber SQL Injection in WP w3all phpBB <= 3.0.5 versions.
high 7.1 CVE-2025-32575 · published 2025-04-09
Cross-site request forgery (CSRF) in WP w3all phpBB (2.9.9 and older)
- Affected
- 2.9.9 and older
- Fixed in
- 3.0.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in axew3 WP w3all phpBB wp-w3all-phpbb-integration allows Reflected XSS.This issue affects WP w3all phpBB: from n/a through <= 2.9.9.
medium 4.3 CVE-2025-32274 · published 2025-04-04
Cross-site request forgery (CSRF) in WP w3all phpBB (2.9.8 and older)
- Affected
- 2.9.8 and older
- Fixed in
- 2.9.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in axew3 WP w3all phpBB wp-w3all-phpbb-integration allows Cross Site Request Forgery.This issue affects WP w3all phpBB: from n/a through <= 2.9.8.
Recent activity
- 2026-11-03 — latest release on wordpress.org (3.2.0).
- 2026-10-14 — Stored cross-site scripting (XSS) disclosed (CVE-2026-107422), fixed in 3.1.2.
- 2026-08-27 — Cross-site scripting (XSS) disclosed (CVE-2026-78293), fixed in 3.0.7.
- 2026-08-20 — SQL injection disclosed (CVE-2026-73998), fixed in 3.0.6.
Get an email when WP w3all phpBB has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP w3all phpBB (wp-w3all-phpbb-integration) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (2) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-w3all-phpbb-integration (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-w3all-phpbb-integration"><img src="https://laskyr.com/plugins/wp-w3all-phpbb-integration/badge.svg" alt="WP w3all phpBB vulnerability status"></a>