Skip to content
Laskyr

Plugins · wp-voting-contest · data as of 2026-11-04

Is WP Voting Contest Lite safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (6.0)

As of 2026-11-04. 2 issues are on record for older versions; version 6.0 or newer fixes all of them that state a fix.

Latest version
6.0
Last updated
2026-07-31
Active installs
400+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.2+

Let visitors vote on the photos and images in your contests. — by Matt

What to do

  1. Update to the latest version (6.0). Anything older than 6.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-voting-contest --field=version shows what you run; wp plugin update wp-voting-contest updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2025-60086 · published 2025-12-18

Missing authorization check in WP Voting Contest Lite (5.8 and older)

Affected
5.8 and older
Fixed in
6.0 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Matt WP Voting Contest wp-voting-contest allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Voting Contest: from n/a through <= 5.8.

NVD CVE-2025-60086Patchstack advisory

medium 5.9 CVE-2025-50017 · published 2025-06-20

Stored cross-site scripting (XSS) in WP Voting Contest Lite (5.8 and older)

Affected
5.8 and older
Fixed in
6.0 *
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Matt WP Voting Contest wp-voting-contest allows Stored XSS.This issue affects WP Voting Contest: from n/a through <= 5.8.

NVD CVE-2025-50017Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Voting Contest Lite vulnerability status badge
<a href="https://laskyr.com/plugins/wp-voting-contest"><img src="https://laskyr.com/plugins/wp-voting-contest/badge.svg" alt="WP Voting Contest Lite vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit