Skip to content
Laskyr

Plugins · wp-travel-blocks · data as of 2026-11-04

Is WP Travel Gutenberg Blocks safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.9.9)

As of 2026-11-04. 5 issues are on record for older versions; version 3.9.5 or newer fixes all of them that state a fix.

Latest version
3.9.9
Last updated
2026-10-12
Active installs
800+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WP Travel Gutenberg Blocks is the easiest, most flexible way to display your Trips using the Gutenberg blocks. — by WP Travel

What to do

  1. Update to the latest version (3.9.9). Anything older than 3.9.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-travel-blocks --field=version shows what you run; wp plugin update wp-travel-blocks updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.3 CVE-2026-54808 · published 2026-06-17

SQL injection in WP Travel Gutenberg Blocks (3.9.4 and older)

Affected
3.9.4 and older
Fixed in
3.9.5
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in WP Travel WP Travel Gutenberg Blocks allows Blind SQL Injection. This issue affects WP Travel Gutenberg Blocks: from n/a through 3.9.4.

NVD CVE-2026-54808Patchstack advisory

medium 6.5 CVE-2025-62063 · published 2025-10-22

Cross-site scripting (XSS) in WP Travel Gutenberg Blocks (3.9.2 and older)

Affected
3.9.2 and older
Fixed in
3.9.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Travel WP Travel Gutenberg Blocks wp-travel-blocks.This issue affects WP Travel Gutenberg Blocks: from n/a through <= 3.9.2.

NVD CVE-2025-62063Patchstack advisory

high 8.1 CVE-2025-53207 · published 2025-08-20

File inclusion in WP Travel Gutenberg Blocks (3.9.0 and older)

Affected
3.9.0 and older
Fixed in
3.9.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in WP Travel WP Travel Gutenberg Blocks wp-travel-blocks allows PHP Local File Inclusion.This issue affects WP Travel Gutenberg Blocks: from n/a through <= 3.9.0.

NVD CVE-2025-53207Patchstack advisory

medium 6.5 CVE-2024-47627 · published 2024-10-05

Stored cross-site scripting (XSS) in WP Travel Gutenberg Blocks (3.6.0 and older)

Affected
3.6.0 and older
Fixed in
3.7.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Travel WP Travel Gutenberg Blocks wp-travel-blocks allows Stored XSS.This issue affects WP Travel Gutenberg Blocks: from n/a through <= 3.6.0.

NVD CVE-2024-47627Patchstack advisory

medium 6.5 CVE-2024-43284 · published 2024-08-18

Stored cross-site scripting (XSS) in WP Travel Gutenberg Blocks (3.5.1 and older)

Affected
3.5.1 and older
Fixed in
3.6.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in WP Travel WP Travel Gutenberg Blocks allows Stored XSS.This issue affects WP Travel Gutenberg Blocks: from n/a through 3.5.1.

NVD CVE-2024-43284Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Travel Gutenberg Blocks vulnerability status badge
<a href="https://laskyr.com/plugins/wp-travel-blocks"><img src="https://laskyr.com/plugins/wp-travel-blocks/badge.svg" alt="WP Travel Gutenberg Blocks vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit