Skip to content
Laskyr

Plugins · wp-terms-popup · data as of 2026-11-04

Is WP Terms Popup safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.11.0)

As of 2026-11-04. 2 issues are on record for older versions; version 2.11.0 or newer fixes all of them that state a fix.

Latest version
2.11.0
Last updated
2026-03-02
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 5.6+

Use WP Terms Popup to ask visitors to agree to your terms and conditions or privacy policy before they are allowed to view your site. — by Link Software LLC

What to do

  1. Update to the latest version (2.11.0). Anything older than 2.11.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-terms-popup --field=version shows what you run; wp plugin update wp-terms-popup updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-32495 · published 2026-03-25

Missing authorization check in WP Terms Popup (2.10.0 and older)

Affected
2.10.0 and older
Fixed in
2.11.0
Access needed (per CVSS)
No login needed
Range from
advisory text · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Link Software LLC WP Terms Popup wp-terms-popup allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Terms Popup: from n/a through <= 2.10.0.

NVD CVE-2026-32495Patchstack advisory

medium 4.8 CVE-2023-24006 · published 2023-04-06

Cross-site scripting (XSS) in WP Terms Popup (2.6.0 and older)

Affected
2.6.0 and older
Fixed in
2.6.1
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Cross-Site Scripting (XSS) vulnerability in Link Software LLC WP Terms Popup plugin <= 2.6.0 versions.

NVD CVE-2023-24006Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Terms Popup vulnerability status badge
<a href="https://laskyr.com/plugins/wp-terms-popup"><img src="https://laskyr.com/plugins/wp-terms-popup/badge.svg" alt="WP Terms Popup vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit