Skip to content
Laskyr

Plugins · wp-super-cache · data as of 2026-11-01

Is WP Super Cache safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.4)

As of 2026-11-01. 3 issues are on record for older versions; version 1.7.3 or newer fixes all of them that state a fix.

Latest version
3.1.4
Last updated
2026-09-30
Active installs
1+ million
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

A very fast caching engine for WordPress that produces static html files. — by Automattic

What to do

  1. Update to the latest version (3.1.4). Anything older than 1.7.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-super-cache --field=version shows what you run; wp plugin update wp-super-cache updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2021-24329 · published 2021-06-01

Stored cross-site scripting (XSS) in WP Super Cache (older than 1.7.3)

Affected
older than 1.7.3
Fixed in
1.7.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The WP Super Cache WordPress plugin before 1.7.3 did not properly sanitise its wp_cache_location parameter in its settings, which could lead to a Stored Cross-Site Scripting issue.

NVD CVE-2021-24329WPScan advisorym0ze.ru

high 7.2 CVE-2021-24312 · published 2021-06-01

Remote code execution in WP Super Cache (older than 1.7.3)

Affected
older than 1.7.3
Fixed in
1.7.3
Access needed (per CVSS)
Needs an admin-level account
Range from
NVD analysis · score by NVD
Details from the advisory

The parameters $cache_path, $wp_cache_debug_ip, $wp_super_cache_front_page_text, $cache_scheduled_time, $cached_direct_pages used in the settings of WP Super Cache WordPress plugin before 1.7.3 result in RCE because they allow input of '$' and '\n'. This is due to an incomplete fix of CVE-2021-24209.

NVD CVE-2021-24312WPScan advisory

high 7.2 CVE-2021-24209 · published 2021-04-05

Remote code execution in WP Super Cache (older than 1.7.2)

Affected
older than 1.7.2
Fixed in
1.7.2
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Super Cache WordPress plugin before 1.7.2 was affected by an authenticated (admin+) RCE in the settings page due to input validation failure and weak $cache_path check in the WP Super Cache Settings -> Cache Location option. Direct access to the wp-cache-config.php file is not prohibited, so this vulnerability can be exploited for a web shell injection.

NVD CVE-2021-24209WPScan advisoryCode change (fix)

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Super Cache vulnerability status badge
<a href="https://laskyr.com/plugins/wp-super-cache"><img src="https://laskyr.com/plugins/wp-super-cache/badge.svg" alt="WP Super Cache vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit