Plugins · wp-subscribe · data as of 2026-11-04
Is WP Subscribe safe? Known vulnerabilities and latest version
- Latest version
- 1.2.16
- Last updated
- 2022-05-10
- Active installs
- 7,000+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 5.9.20
WP Subscribe is a simple but powerful subscription plugin which supports MailChimp, Aweber and Feedburner. — by MyThemeShop
What to do
- There is no fixed version yet. If you can live without WP Subscribe for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get wp-subscribe --field=version shows what you run; wp plugin update wp-subscribe updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 affects latest 1.2.16 CVE-2026-24522 · published 2026-01-23
Missing authorization check in WP Subscribe (1.2.16 and older)
- Affected
- 1.2.16 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in MyThemeShop WP Subscribe wp-subscribe allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Subscribe: from n/a through <= 1.2.16.
medium 4.8 CVE-2021-36844 · published 2022-05-02
Stored cross-site scripting (XSS) in WP Subscribe (1.2.12 and older)
- Affected
- 1.2.12 and older
- Fixed in
- 1.2.13 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Authenticated (admin+) Stored Cross-Site Scripting (XSS) vulnerability in MyThemeShop WP Subscribe plugin <= 1.2.12 on WordPress.
Recent activity
- 2022-05-10 — latest release on wordpress.org (1.2.16).
- 2026-01-23 — Missing authorization check disclosed (CVE-2026-24522), no fix listed yet.
- 2022-05-02 — Stored cross-site scripting (XSS) disclosed (CVE-2021-36844), fixed in 1.2.13.
Get an email when WP Subscribe has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Subscribe (wp-subscribe) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by MyThemeShop (2 tracked)
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-subscribe (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-subscribe"><img src="https://laskyr.com/plugins/wp-subscribe/badge.svg" alt="WP Subscribe vulnerability status"></a>