Skip to content
Laskyr

Plugins · wp-store-locator · data as of 2026-11-04

Is WP Store Locator safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.1.1)

As of 2026-11-04. 4 issues are on record for older versions; version 3.1.0 or newer fixes all of them that state a fix.

Latest version
3.1.1
Last updated
2026-11-03
Active installs
40,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Free store locator with OpenStreetMap maps and no API key. Or use Google Maps, Mapbox or Stadia Maps. Unlimited locations, custom fields and markers. — by tijmensmit

What to do

  1. Update to the latest version (3.1.1). Anything older than 3.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-store-locator --field=version shows what you run; wp plugin update wp-store-locator updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-105078 · published 2026-10-08

Stored cross-site scripting (XSS) in WP Store Locator (3.0.3 and older)

Affected
3.0.3 and older
Fixed in
3.1.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Store Locator WP Store Locator wp-store-locator allows Stored XSS.This issue affects WP Store Locator: from n/a through 3.0.3.

NVD CVE-2026-105078Patchstack advisory

medium 5.9 CVE-2026-94681 · published 2026-09-30

Denial of service in WP Store Locator (older than 3.0.0)

Affected
older than 3.0.0
Fixed in
3.0.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Denial of Service Attack in WP Store Locator < 3.0.0 versions.

NVD CVE-2026-94681Patchstack advisory

medium 6.4 CVE-2026-3361 · published 2026-04-23

Stored cross-site scripting (XSS) in WP Store Locator (2.2.261 and older)

Affected
2.2.261 and older
Fixed in
2.3.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Store Locator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wpsl_address' post meta value in versions up to, and including, 2.2.261 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page and opens an injected map marker info window.

NVD CVE-2026-3361Wordfence advisoryCode change (fix)

high 8.8 CVE-2025-52737 · published 2025-10-22

PHP object injection in WP Store Locator (2.2.260 and older)

Affected
2.2.260 and older
Fixed in
2.2.261
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Tijmen Smit WP Store Locator wp-store-locator allows Object Injection.This issue affects WP Store Locator: from n/a through <= 2.2.260.

NVD CVE-2025-52737Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Store Locator vulnerability status badge
<a href="https://laskyr.com/plugins/wp-store-locator"><img src="https://laskyr.com/plugins/wp-store-locator/badge.svg" alt="WP Store Locator vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit