Skip to content
Laskyr

Plugins · wp-stats · data as of 2026-11-04

Is WP-Stats safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.1)

As of 2026-11-04. 3 issues are on record for older versions; version 2.56.1 or newer fixes all of them that state a fix.

Latest version
3.0.1
Last updated
2026-09-01
Active installs
2,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

Display your WordPress blog statistics. Ranging from general total statistics, some of my plugins statistics and top 10 statistics. — by Lester Chan

What to do

  1. Update to the latest version (3.0.1). Anything older than 2.56.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-stats --field=version shows what you run; wp plugin update wp-stats updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.2 CVE-2026-19794 · published 2026-08-14

Stored cross-site scripting (XSS) in WP-Stats (2.56 and older)

Affected
2.56 and older
Fixed in
2.56.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP-Stats plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 2.56 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-19794Wordfence advisoryPatchstack advisory

high 7.1 CVE-2026-66426 · published 2026-08-13

Cross-site scripting (XSS) in WP-Stats (2.56 and older)

Affected
2.56 and older
Fixed in
2.56.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in WP-Stats <= 2.56 versions.

NVD CVE-2026-66426Patchstack advisory

medium 4.3 CVE-2015-10001 · published 2021-11-01

Cross-site request forgery (CSRF) in WP-Stats (older than 2.52)

Affected
older than 2.52
Fixed in
2.52
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The WP-Stats WordPress plugin before 2.52 does not have CSRF check when saving its settings, and did not escape some of them when outputting them, allowing attacker to make logged in high privilege users change them and set Cross-Site Scripting payloads

NVD CVE-2015-10001WPScan advisoryopenwall.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP-Stats vulnerability status badge
<a href="https://laskyr.com/plugins/wp-stats"><img src="https://laskyr.com/plugins/wp-stats/badge.svg" alt="WP-Stats vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit