Skip to content
Laskyr

Plugins · wp-stateless · data as of 2026-11-04

Is WP-Stateless safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.4.3)

As of 2026-11-04. 2 issues are on record for older versions; version 4.4.2 or newer fixes all of them that state a fix.

Latest version
4.4.3
Last updated
2026-09-05
Active installs
4,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 8.1+

Upload and serve your WordPress media files from Google Cloud Storage. — by UDX Usability Dynamics

What to do

  1. Update to the latest version (4.4.3). Anything older than 4.4.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-stateless --field=version shows what you run; wp plugin update wp-stateless updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.1 CVE-2026-81801 · published 2026-09-10

Missing authorization check in WP-Stateless (4.4.1 and older)

Affected
4.4.1 and older
Fixed in
4.4.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Settings Change in WP-Stateless <= 4.4.1 versions.

NVD CVE-2026-81801Patchstack advisory

high 7.1 CVE-2024-1385 · published 2024-04-06

Missing authorization check in WP-Stateless (3.4.0 and older)

Affected
3.4.0 and older
Fixed in
3.4.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP-Stateless – Google Cloud Storage plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the dismiss_notices() function in all versions up to, and including, 3.4.0. This makes it possible for authenticated attackers, with subscriber-level access and above, to update arbitrary option values to the current time, which may completely take a site offline.

NVD CVE-2024-1385Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP-Stateless vulnerability status badge
<a href="https://laskyr.com/plugins/wp-stateless"><img src="https://laskyr.com/plugins/wp-stateless/badge.svg" alt="WP-Stateless vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit