Plugins · wp-smushit · data as of 2026-11-01
Is Smush safe? Known vulnerabilities and latest version
- Latest version
- 4.3.5
- Last updated
- 2026-10-20
- Active installs
- 1+ million
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Compress and optimize images, enable lazy load, serve WebP & AVIF, and speed up your site with a global image CDN. — by WPMU DEV - Your All-in-One WordPress Platform
What to do
- Update to the latest version (4.3.5). Anything older than 4.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-smushit --field=version shows what you run; wp plugin update wp-smushit updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-81285 · published 2026-08-28
Denial of service in Smush (4.2.0 and older)
- Affected
- 4.2.0 and older
- Fixed in
- 4.3.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Denial of Service Attack in Smush Image Compression and Optimization <= 4.2.0 versions.
medium 4.1 CVE-2025-22288 · published 2025-11-06
Path traversal / file read in Smush (3.17.0 and older)
- Affected
- 3.17.0 and older
- Fixed in
- 3.17.1
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Path Traversal: '.../...//' vulnerability in WPMU DEV - Your All-in-One WordPress Platform Smush Image Compression and Optimization wp-smushit allows Path Traversal.This issue affects Smush Image Compression and Optimization: from n/a through <= 3.17.0.
medium 4.3 CVE-2023-3352 · published 2024-06-21
Missing authorization check in Smush (3.16.4 and older)
- Affected
- 3.16.4 and older
- Fixed in
- 3.16.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Smush plugin for WordPress is vulnerable to unauthorized deletion of the resmush list due to a missing capability check on the delete_resmush_list() function. This makes it possible for authenticated attackers, with minimal permissions such as a subscriber, to delete the resmush list for Nextgen or the Media Library.
high 7.5 CVE-2017-15079 · published 2017-10-06
Path traversal / file read in Smush (older than 2.7.6)
- Affected
- older than 2.7.6
- Fixed in
- 2.7.6
- Access needed (per CVSS)
- No login needed
- Range from
- advisory text · score by NVD
Details from the advisory
The Smush Image Compression and Optimization plugin before 2.7.6 for WordPress allows directory traversal.
Recent activity
- 2026-10-20 — latest release on wordpress.org (4.3.5).
- 2026-08-28 — Denial of service disclosed (CVE-2026-81285), fixed in 4.3.0.
- 2025-11-06 — Path traversal / file read disclosed (CVE-2025-22288), fixed in 3.17.1.
- 2024-06-21 — Missing authorization check disclosed (CVE-2023-3352), fixed in 3.16.5.
Get an email when Smush has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Smush (wp-smushit) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-smushit (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-smushit"><img src="https://laskyr.com/plugins/wp-smushit/badge.svg" alt="Smush vulnerability status"></a>