Plugins · wp-simple-html-sitemap · data as of 2026-11-04
Is WP Simple HTML Sitemap safe? Known vulnerabilities and latest version
- Latest version
- 3.9
- Last updated
- 2026-07-02
- Active installs
- 3,000+
- Known issues on record
- 7
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Using Simple HTML Sitemap plugin, you can add HTML Sitemap anywhere on the website using Shortcode. — by Ashish Ajani
What to do
- Update to the latest version (3.9). Anything older than 3.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-simple-html-sitemap --field=version shows what you run; wp plugin update wp-simple-html-sitemap updates it.
Check your version
Known vulnerabilities
7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.9 CVE-2026-39654 · published 2026-04-08
Cross-site scripting (XSS) in WP Simple HTML Sitemap (3.8 and older)
- Affected
- 3.8 and older
- Fixed in
- 3.9 *
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ashish Ajani WP Simple HTML Sitemap wp-simple-html-sitemap allows DOM-Based XSS.This issue affects WP Simple HTML Sitemap: from n/a through <= 3.8.
medium 5.3 CVE-2025-31822 · published 2025-04-01
Missing authorization check in WP Simple HTML Sitemap (3.5 and older)
- Affected
- 3.5 and older
- Fixed in
- 3.6
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Ashish Ajani WP Simple HTML Sitemap wp-simple-html-sitemap allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Simple HTML Sitemap: from n/a through <= 3.5.
medium 5.3 CVE-2023-49850 · published 2024-12-09
Missing authorization check in WP Simple HTML Sitemap (2.7 and older)
- Affected
- 2.7 and older
- Fixed in
- 2.8
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Ashish Ajani WP Simple HTML Sitemap allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Simple HTML Sitemap: from n/a through 2.7.
high 7.2 CVE-2024-7385 · published 2024-09-25
SQL injection in WP Simple HTML Sitemap (3.1 and older)
- Affected
- 3.1 and older
- Fixed in
- 3.2 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WordPress Simple HTML Sitemap plugin for WordPress is vulnerable to SQL Injection via the 'id' parameter in all versions up to, and including, 3.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
NVD CVE-2024-7385Wordfence advisoryCode change (fix)Plugin source
high 7.1 CVE-2024-32574 · published 2024-04-18
Reflected cross-site scripting (XSS) in WP Simple HTML Sitemap (2.8 and older)
- Affected
- 2.8 and older
- Fixed in
- 2.9
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ashish Ajani WP Simple HTML Sitemap allows Reflected XSS.This issue affects WP Simple HTML Sitemap: from n/a through 2.8.
medium 6.1 CVE-2023-46627 · published 2023-11-08
Reflected cross-site scripting (XSS) in WP Simple HTML Sitemap (2.1 and older)
- Affected
- 2.1 and older
- Fixed in
- 2.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Unauth. Reflected Cross-Site Scripting (XSS) vulnerability in Ashish Ajani WordPress Simple HTML Sitemap plugin <= 2.1 versions.
medium 5.4 CVE-2023-45067 · published 2023-10-18
Stored cross-site scripting (XSS) in WP Simple HTML Sitemap (2.1 and older)
- Affected
- 2.1 and older
- Fixed in
- 2.2 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Ashish Ajani WordPress Simple HTML Sitemap plugin <= 2.1 versions.
Recent activity
- 2026-07-02 — latest release on wordpress.org (3.9).
- 2026-04-08 — Cross-site scripting (XSS) disclosed (CVE-2026-39654), fixed in 3.9.
- 2025-04-01 — Missing authorization check disclosed (CVE-2025-31822), fixed in 3.6.
- 2024-12-09 — Missing authorization check disclosed (CVE-2023-49850), fixed in 2.8.
Get an email when WP Simple HTML Sitemap has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Simple HTML Sitemap (wp-simple-html-sitemap) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · Missing authorization (2) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-simple-html-sitemap (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-simple-html-sitemap"><img src="https://laskyr.com/plugins/wp-simple-html-sitemap/badge.svg" alt="WP Simple HTML Sitemap vulnerability status"></a>