Skip to content
Laskyr

Plugins · wp-showhide · data as of 2026-11-04

Is WP-ShowHide safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.0.0)

As of 2026-11-04. 2 issues are on record for older versions; version 1.06 or newer fixes all of them that state a fix.

Latest version
3.0.0
Last updated
2026-08-09
Active installs
9,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 8.2+

Allows you to embed content within your blog post via WordPress ShortCode API and toggling the visibility of the content via a button. — by Lester Chan

What to do

  1. Update to the latest version (3.0.0). Anything older than 1.06 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-showhide --field=version shows what you run; wp plugin update wp-showhide updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2025-67541 · published 2025-12-09

Stored cross-site scripting (XSS) in WP-ShowHide (1.05 and older)

Affected
1.05 and older
Fixed in
1.06
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Lester Chan WP-ShowHide wp-showhide allows Stored XSS.This issue affects WP-ShowHide: from n/a through <= 1.05.

NVD CVE-2025-67541Patchstack advisory

medium 5.4 CVE-2022-4825 · published 2023-02-06

Stored cross-site scripting (XSS) in WP-ShowHide (older than 1.05)

Affected
older than 1.05
Fixed in
1.05
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP-ShowHide WordPress plugin before 1.05 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

NVD CVE-2022-4825WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP-ShowHide vulnerability status badge
<a href="https://laskyr.com/plugins/wp-showhide"><img src="https://laskyr.com/plugins/wp-showhide/badge.svg" alt="WP-ShowHide vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit