Plugins · wp-shortcode · data as of 2026-11-04
Is WP Shortcode by MyThemeShop safe? Known vulnerabilities and latest version
- Status
- Closed 2026-08-10
- Known issues on record
- 2
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate wp-shortcode && wp plugin delete wp-shortcode
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.
medium 6.4 CVE-2026-9635 · published 2026-07-23
Stored cross-site scripting (XSS) in WP Shortcode by MyThemeShop (1.4.17 and older)
- Affected
- 1.4.17 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Shortcode by MyThemeShop plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'title' parameter of the [tab] shortcode in versions up to, and including, 1.4.17. This is due to insufficient input sanitization and output escaping in the mts_tabs() function, which outputs the title shortcode attribute directly into the HTML output between anchor tags without applying any escaping functions. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
high 8.8 CVE-2023-28495 · published 2023-11-12
Cross-site request forgery (CSRF) in WP Shortcode by MyThemeShop (1.4.16 and older)
- Affected
- 1.4.16 and older
- Fixed in
- 1.4.17
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in MyThemeShop WP Shortcode by MyThemeShop plugin <= 1.4.16 versions.
Recent activity
- 2026-08-10 — closed on wordpress.org (Security Issue).
- 2026-07-23 — Stored cross-site scripting (XSS) disclosed (CVE-2026-9635), fix version not stated.
- 2023-11-12 — Cross-site request forgery (CSRF) disclosed (CVE-2023-28495), fixed in 1.4.17.
Get an email when WP Shortcode by MyThemeShop has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Shortcode by MyThemeShop (wp-shortcode) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/wp-shortcode (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-shortcode"><img src="https://laskyr.com/plugins/wp-shortcode/badge.svg" alt="WP Shortcode by MyThemeShop vulnerability status"></a>