Skip to content
Laskyr

Plugins · wp-rollback · data as of 2026-11-04

Is WP Rollback safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.2.0)

As of 2026-11-04. 3 issues are on record for older versions; version 3.2.0 or newer fixes all of them that state a fix.

Latest version
3.2.0
Last updated
2026-10-08
Active installs
200,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Roll back (or forward) any WordPress.org plugin, theme, or block like a boss. — by Devin Walker

What to do

  1. Update to the latest version (3.2.0). Anything older than 3.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-rollback --field=version shows what you run; wp plugin update wp-rollback updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.9 CVE-2026-66435 · published 2026-10-10

Information disclosure in WP Rollback (3.1.2 and older)

Affected
3.1.2 and older
Fixed in
3.2.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Insertion of Sensitive Information Into Sent Data vulnerability in Devin Walker WP Rollback wp-rollback allows Retrieve Embedded Sensitive Data.This issue affects WP Rollback: from n/a through 3.1.2.

NVD CVE-2026-66435Patchstack advisory

medium 6.1 CVE-2015-9342 · published 2019-08-27

Cross-site scripting (XSS) in WP Rollback (older than 1.2.3)

Affected
older than 1.2.3
Fixed in
1.2.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The wp-rollback plugin before 1.2.3 for WordPress has XSS.

NVD CVE-2015-9342wordpress.org

high 8.8 CVE-2015-9343 · published 2019-08-27

Cross-site request forgery (CSRF) in WP Rollback (older than 1.2.3)

Affected
older than 1.2.3
Fixed in
1.2.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The wp-rollback plugin before 1.2.3 for WordPress has CSRF.

NVD CVE-2015-9343wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Rollback vulnerability status badge
<a href="https://laskyr.com/plugins/wp-rollback"><img src="https://laskyr.com/plugins/wp-rollback/badge.svg" alt="WP Rollback vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit