Skip to content
Laskyr

Plugins · wp-reviews-plugin-for-google · data as of 2026-11-01

Is Widgets for Google Reviews safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (14.3)

As of 2026-11-01. 6 issues are on record for older versions; version 13.3.2 or newer fixes all of them that state a fix.

Latest version
14.3
Last updated
2026-10-29
Active installs
1+ million
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.2+

Google Reviews Widget for WordPress. Display Google reviews in 1 minute with 45 professional layouts. Build trust, boost SEO, and increase sales. — by Trustindex

What to do

  1. Update to the latest version (14.3). Anything older than 13.3.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-reviews-plugin-for-google --field=version shows what you run; wp plugin update wp-reviews-plugin-for-google updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-11591 · published 2026-07-11

Stored cross-site scripting (XSS) in Widgets for Google Reviews (13.3 and older)

Affected
13.3 and older
Fixed in
13.3.2 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Widgets for Google Reviews plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in all versions up to, and including, 13.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with editor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2026-11591Wordfence advisoryCode change (fix)Plugin source

medium 6.4 CVE-2025-9436 · published 2025-12-11

Stored cross-site scripting (XSS) in Widgets for Google Reviews (13.2.1 and older)

Affected
13.2.1 and older
Fixed in
13.2.9 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Widgets for Google Reviews plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `trustindex` shortcode in all versions up to, and including, 13.2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-9436Wordfence advisoryPlugin source

high 7.2 CVE-2025-12510 · published 2025-12-06

Stored cross-site scripting (XSS) in Widgets for Google Reviews (13.2.4 and older)

Affected
13.2.4 and older
Fixed in
13.2.9 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Widgets for Google Reviews plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 13.2.4 due to insufficient input sanitization and output escaping on Google Reviews data imported by the plugin. This makes it possible for unauthenticated attackers to inject arbitrary web scripts that will execute in the admin panel (and potentially on the frontend) whenever a user accesses imported reviews, granted they can add a malicious review to a Google Place that is connected to the vulnerable site.

NVD CVE-2025-12510Wordfence advisoryCode change (fix)Plugin source

high 8.0 CVE-2023-48275 · published 2024-03-26

Arbitrary file upload in Widgets for Google Reviews (11.0.2 and older)

Affected
11.0.2 and older
Fixed in
11.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unrestricted Upload of File with Dangerous Type vulnerability in Trustindex.Io Widgets for Google Reviews.This issue affects Widgets for Google Reviews: from n/a through 11.0.2.

NVD CVE-2023-48275Patchstack advisory

medium 4.3 CVE-2023-3254 · published 2023-10-18

Cross-site request forgery (CSRF) in Widgets for Google Reviews (10.9 and older)

Affected
10.9 and older
Fixed in
10.9.1 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Widgets for Google Reviews plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 10.9. This is due to missing or incorrect nonce validation within setup_no_reg_header.php. This makes it possible for unauthenticated attackers to reset plugin settings and remove reviews via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

NVD CVE-2023-3254Wordfence advisoryCode change (fix)

medium 5.4 CVE-2022-4470 · published 2023-01-30

Stored cross-site scripting (XSS) in Widgets for Google Reviews (older than 9.8)

Affected
older than 9.8
Fixed in
9.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Widgets for Google Reviews WordPress plugin before 9.8 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

NVD CVE-2022-4470WPScan advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Widgets for Google Reviews vulnerability status badge
<a href="https://laskyr.com/plugins/wp-reviews-plugin-for-google"><img src="https://laskyr.com/plugins/wp-reviews-plugin-for-google/badge.svg" alt="Widgets for Google Reviews vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit