Skip to content
Laskyr

Plugins · wp-retina-2x · data as of 2026-11-04

Is Perfect Images safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (7.2.5)

As of 2026-11-04. 3 issues are on record for older versions; version 7.2.1 or newer fixes all of them that state a fix.

Latest version
7.2.5
Last updated
2026-11-03
Active installs
60,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.1+

Optimize image sizes, regenerate thumbnails, enable retina, convert to WebP/AVIF, or use cloud optimization. An essential image toolkit. — by Jordy Meow

What to do

  1. Update to the latest version (7.2.5). Anything older than 7.2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-retina-2x --field=version shows what you run; wp plugin update wp-retina-2x updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-11455 · published 2026-10-31

Missing authorization check in Perfect Images (7.2.0 and older)

Affected
7.2.0 and older
Fixed in
7.2.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Perfect Images plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the /wp-json/wp-retina-2x/v1/replace REST API in all versions up to, and including, 7.2.0 This makes it possible for authenticated attackers, with Author-level access and above, to replace files that do not belong to them.

NVD CVE-2025-11455Wordfence advisoryCode change (fix)

high 7.5 CVE-2023-44982 · published 2023-12-19

Information disclosure in Perfect Images (6.4.5 and older)

Affected
6.4.5 and older
Fixed in
6.4.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Jordy Meow Perfect Images (Manage Image Sizes, Thumbnails, Replace, Retina).This issue affects Perfect Images (Manage Image Sizes, Thumbnails, Replace, Retina): from n/a through 6.4.5.

NVD CVE-2023-44982Patchstack advisory

medium 6.1 CVE-2018-20983 · published 2019-08-22

Cross-site scripting (XSS) in Perfect Images (older than 5.2.3)

Affected
older than 5.2.3
Fixed in
5.2.3
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The wp-retina-2x plugin before 5.2.3 for WordPress has XSS.

NVD CVE-2018-20983wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Perfect Images vulnerability status badge
<a href="https://laskyr.com/plugins/wp-retina-2x"><img src="https://laskyr.com/plugins/wp-retina-2x/badge.svg" alt="Perfect Images vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit