Skip to content
Laskyr

Plugins · wp-rest-cache · data as of 2026-11-04

Is WP REST Cache safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2026.4.2)

As of 2026-11-04. 3 issues are on record for older versions; version 2026.4.0 or newer fixes all of them that state a fix.

Latest version
2026.4.2
Last updated
2026-10-30
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

Enable caching of the WordPress REST API and auto-flush caches upon wp-admin editing. — by Acato

What to do

  1. Update to the latest version (2026.4.2). Anything older than 2026.4.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-rest-cache --field=version shows what you run; wp plugin update wp-rest-cache updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-116862 · published 2026-10-30

Missing authorization check in WP REST Cache (2026.3.1 and older)

Affected
2026.3.1 and older
Fixed in
2026.4.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Broken Access Control in WP REST Cache <= 2026.3.1 versions.

NVD CVE-2026-116862Patchstack advisory

high 7.1 CVE-2026-25347 · published 2026-03-25

Stored cross-site scripting (XSS) in WP REST Cache (2026.1.0 and older)

Affected
2026.1.0 and older
Fixed in
2026.1.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Acato WP REST Cache wp-rest-cache allows Stored XSS.This issue affects WP REST Cache: from n/a through <= 2026.1.0.

NVD CVE-2026-25347Patchstack advisory

high 7.5 CVE-2025-52716 · published 2025-08-14

File inclusion in WP REST Cache (2025.1.0 and older)

Affected
2025.1.0 and older
Fixed in
2025.1.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in Acato WP REST Cache wp-rest-cache allows PHP Local File Inclusion.This issue affects WP REST Cache: from n/a through <= 2025.1.0.

NVD CVE-2025-52716Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP REST Cache vulnerability status badge
<a href="https://laskyr.com/plugins/wp-rest-cache"><img src="https://laskyr.com/plugins/wp-rest-cache/badge.svg" alt="WP REST Cache vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit