Skip to content
Laskyr

Plugins · wp-rest-api-log · data as of 2026-11-04

Is REST API Log safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7.3)

As of 2026-11-04. 3 issues are on record for older versions; version 1.7.3 or newer fixes all of them that state a fix.

Latest version
1.7.3
Last updated
2026-09-25
Active installs
5,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

WordPress plugin to log REST API requests and responses — by Pete Nelson

What to do

  1. Update to the latest version (1.7.3). Anything older than 1.7.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-rest-api-log --field=version shows what you run; wp plugin update wp-rest-api-log updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.5 CVE-2026-100514 · published 2026-10-01

Missing authorization check in REST API Log (1.7.2 and older)

Affected
1.7.2 and older
Fixed in
1.7.3
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Insecure Direct Object References (IDOR) in REST API Log <= 1.7.2 versions.

NVD CVE-2026-100514Patchstack advisory

high 7.5 CVE-2026-66443 · published 2026-08-13

Information disclosure in REST API Log (1.7.1 and older)

Affected
1.7.1 and older
Fixed in
1.7.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Sensitive Data Exposure in REST API Log <= 1.7.1 versions.

NVD CVE-2026-66443Patchstack advisory

medium 5.9 CVE-2026-16547 · published 2026-08-04

Missing authorization check in REST API Log (older than 1.7.1)

Affected
older than 1.7.1
Fixed in
1.7.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The REST API Log WordPress plugin before 1.7.1 does not bind the token protecting its log download feature to the log entry being requested, nor does it check the capability of the requester, allowing unauthenticated users in possession of any such token to download the logged REST API requests and responses of any entry, which may contain sensitive data such as credentials, authentication tokens or private content.

NVD CVE-2026-16547WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
REST API Log vulnerability status badge
<a href="https://laskyr.com/plugins/wp-rest-api-log"><img src="https://laskyr.com/plugins/wp-rest-api-log/badge.svg" alt="REST API Log vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit