Skip to content
Laskyr

Plugins · wp-responsive-thumbnail-slider · data as of 2026-11-04

Is Responsive Thumbnail Slider safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.53)

As of 2026-11-04. 4 issues are on record for older versions; version 1.1.53 or newer fixes all of them that state a fix.

Latest version
1.1.53
Last updated
2026-09-02
Active installs
1,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4

A fast, lightweight responsive thumbnail slider for WordPress — modern animation engine, lightbox, captions, and full theme/builder compatibility. — by Nks

What to do

  1. Update to the latest version (1.1.53). Anything older than 1.1.53 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-responsive-thumbnail-slider --field=version shows what you run; wp plugin update wp-responsive-thumbnail-slider updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-18344 · published 2026-08-01

Reflected cross-site scripting (XSS) in Responsive Thumbnail Slider (older than 1.1.53)

Affected
older than 1.1.53
Fixed in
1.1.53
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Wp Responsive Thumbnail Slider plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'id' parameter in versions up to, and excluding, 1.1.53. This is due to insufficient input sanitization and output escaping in the responsive_thumbnail_image_management() function, which echoes $_GET['id'] directly into a double-quoted HTML attribute with no esc_attr() call. The only guard is a loose PHP numeric comparison ($_GET['id']>0) that a string beginning with a numeric prefix trivially satisfies, and the addslashes() applied by wp_magic_quotes() is inert in HTML-attribute context because backslash is not an HTML escape character. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a specially crafted link.

NVD CVE-2026-18344Wordfence advisoryPlugin source

high 8.8 CVE-2015-10144 · published 2025-07-25

Arbitrary file upload in Responsive Thumbnail Slider (older than 1.0.1)

Affected
older than 1.0.1
Fixed in
1.0.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Responsive Thumbnail Slider plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type sanitization in the via the image uploader in versions up to 1.0.1. This makes it possible for authenticated attackers, with subscriber-level access and above, to upload arbitrary files on the affected sites server using a double extension which may make remote code execution possible.

NVD CVE-2015-10144Wordfence advisorycxsecurity.comraw.githubusercontent.comacunetix.comexploit-db.com

medium 4.9 CVE-2019-25222 · published 2025-03-15

SQL injection in Responsive Thumbnail Slider (1.0.4 and older)

Affected
1.0.4 and older
Fixed in
1.0.5 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Thumbnail carousel slider plugin for WordPress is vulnerable to SQL Injection via the 'id' parameter in all versions up to, and including, 1.0.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2019-25222Wordfence advisorywordpress.orgPlugin source

medium 6.1 CVE-2023-2120 · published 2023-04-18

Reflected cross-site scripting (XSS) in Responsive Thumbnail Slider (1.1.9 and older)

Affected
1.1.9 and older
Fixed in
1.1.10 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Thumbnail carousel slider plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the search_term parameter in versions up to, and including, 1.1.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2023-2120Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Responsive Thumbnail Slider vulnerability status badge
<a href="https://laskyr.com/plugins/wp-responsive-thumbnail-slider"><img src="https://laskyr.com/plugins/wp-responsive-thumbnail-slider/badge.svg" alt="Responsive Thumbnail Slider vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit