Skip to content
Laskyr

Plugins · wp-reset · data as of 2026-11-01

Is WP Reset safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.08)

As of 2026-11-01. 5 issues are on record for older versions; version 2.06 or newer fixes all of them that state a fix.

Latest version
2.08
Last updated
2026-08-16
Active installs
300,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.2+

WP Reset resets the entire site or selected parts using advanced reset options to default values. 100% safe to use with built-in restore function. — by WebFactory

What to do

  1. Update to the latest version (2.08). Anything older than 2.06 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-reset --field=version shows what you run; wp plugin update wp-reset updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 2 record(s) do not state which versions are affected.

medium 5.3 CVE-2025-10645 · published 2025-10-07

Information disclosure in WP Reset (2.05 and older)

Affected
2.05 and older
Fixed in
2.06 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Reset plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.05 via the WF_Licensing::log() method when debugging is enabled (default). This makes it possible for unauthenticated attackers to extract sensitive license key and site data.

NVD CVE-2025-10645Wordfence advisoryCode change (fix)research.cleantalk.org

medium 4.3 CVE-2024-4661 · published 2024-06-08

Missing authorization check in WP Reset (2.01 and older)

Affected
2.01 and older
Fixed in
2.02 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The WP Reset plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_ajax function in all versions up to, and including, 2.02. This makes it possible for authenticated attackers, with subscriber-level access and above, to modify the value fo the 'License Key' field for the 'Activate Pro License' setting.

NVD CVE-2024-4661Wordfence advisoryCode change (fix)

medium 5.9 CVE-2023-6799 · published 2024-04-09

Information disclosure in WP Reset (2.0 and older)

Affected
2.0 and older
Fixed in
2.01 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The WP Reset – Most Advanced WordPress Reset Tool plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.0 via the use of insufficiently random snapshot names. This makes it possible for unauthenticated attackers to extract sensitive data including site backups by brute-forcing the snapshot filenames. Please note that the vendor does not plan to do any further hardening on this functionality.

NVD CVE-2023-6799Wordfence advisoryCode change (fix)

high 8.8 CVE-2021-36908 · published 2021-11-18

Cross-site request forgery (CSRF) in WP Reset (5.98 and older)

Affected
5.98 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
advisory text · score by NVD

Note: the source's version range goes past the newest WP Reset release on wordpress.org (2.08), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in WebFactory Ltd. WP Reset PRO plugin <= 5.98 versions.

NVD CVE-2021-36908Patchstack advisoryPatchstack advisory

high 8.1 CVE-2021-36909 · published 2021-11-18

Missing authorization check in WP Reset (5.98 and older)

Affected
5.98 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
NVD analysis · score by NVD

Note: the source's version range goes past the newest WP Reset release on wordpress.org (2.08), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.

Details from the advisory

Authenticated Database Reset vulnerability in WordPress WP Reset PRO Premium plugin (versions <= 5.98) allows any authenticated user to wipe the entire database regardless of their authorization. It leads to a complete website reset and takeover.

NVD CVE-2021-36909Patchstack advisoryPatchstack advisorywpreset.com

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Reset vulnerability status badge
<a href="https://laskyr.com/plugins/wp-reset"><img src="https://laskyr.com/plugins/wp-reset/badge.svg" alt="WP Reset vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit