Plugins · wp-quicklatex · data as of 2026-11-04
Is WP QuickLaTeX safe? Known vulnerabilities and latest version
- Latest version
- 3.8.8
- Last updated
- 2024-06-26
- Active installs
- 4,000+
- Known issues on record
- 3
- Unpatched in latest
- 1
- Tested up to WP
- 6.5.14
Advanced LaTeX plugin. Native LaTeX syntax. Allows custom preamble, TikZ and other packages. Zoom-independent visual quality (SVG). — by advanpix
What to do
- There is no fixed version yet. If you can live without WP QuickLaTeX for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get wp-quicklatex --field=version shows what you run; wp plugin update wp-quicklatex updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 affects latest 3.8.8 CVE-2026-81776 · published 2026-09-03
Cross-site scripting (XSS) in WP QuickLaTeX (3.8.8 and older)
- Affected
- 3.8.8 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in WP QuickLaTeX <= 3.8.8 versions.
medium 4.8 CVE-2024-5529 · published 2024-07-22
Stored cross-site scripting (XSS) in WP QuickLaTeX (older than 3.8.8)
- Affected
- older than 3.8.8
- Fixed in
- 3.8.8
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP QuickLaTeX WordPress plugin before 3.8.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
high 7.1 CVE-2024-5472 · published 2024-07-13
Stored cross-site scripting (XSS) in WP QuickLaTeX (older than 3.8.7)
- Affected
- older than 3.8.7
- Fixed in
- 3.8.7
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory
The WP QuickLaTeX WordPress plugin before 3.8.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Recent activity
- 2024-06-26 — latest release on wordpress.org (3.8.8).
- 2026-09-03 — Cross-site scripting (XSS) disclosed (CVE-2026-81776), no fix listed yet.
- 2024-07-22 — Stored cross-site scripting (XSS) disclosed (CVE-2024-5529), fixed in 3.8.8.
- 2024-07-13 — Stored cross-site scripting (XSS) disclosed (CVE-2024-5472), fixed in 3.8.7.
Get an email when WP QuickLaTeX has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP QuickLaTeX (wp-quicklatex) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-quicklatex (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-quicklatex"><img src="https://laskyr.com/plugins/wp-quicklatex/badge.svg" alt="WP QuickLaTeX vulnerability status"></a>