Skip to content
Laskyr

Plugins · wp-quick-post-duplicator · data as of 2026-11-04

Is WP Quick Post Duplicator safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2)

As of 2026-11-04. 2 issues are on record for older versions; version 2.2 or newer fixes all of them that state a fix.

Latest version
2.2
Last updated
2026-01-01
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.8.12

Copy or Duplicate any post types, including pages, taxonomies & custom fields with a single click. — by Arul Prasad J

What to do

  1. Update to the latest version (2.2). Anything older than 2.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get wp-quick-post-duplicator --field=version shows what you run; wp plugin update wp-quick-post-duplicator updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-24387 · published 2026-01-22

Missing authorization check in WP Quick Post Duplicator (2.1 and older)

Affected
2.1 and older
Fixed in
2.2
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Arul Prasad J WP Quick Post Duplicator wp-quick-post-duplicator allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Quick Post Duplicator: from n/a through <= 2.1.

NVD CVE-2026-24387Patchstack advisory

medium 5.4 CVE-2023-31214 · published 2024-12-09

Missing authorization check in WP Quick Post Duplicator (2.0 and older)

Affected
2.0 and older
Fixed in
2.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Arul Prasad J WP Quick Post Duplicator allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Quick Post Duplicator: from n/a through 2.0.

NVD CVE-2023-31214Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
WP Quick Post Duplicator vulnerability status badge
<a href="https://laskyr.com/plugins/wp-quick-post-duplicator"><img src="https://laskyr.com/plugins/wp-quick-post-duplicator/badge.svg" alt="WP Quick Post Duplicator vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit