Plugins · wp-popups-lite · data as of 2026-11-04
Is WP Popups safe? Known vulnerabilities and latest version
- Latest version
- 2.2.0.9
- Last updated
- 2026-10-26
- Active installs
- 30,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.2 · PHP 5.7+
WP Popups is the best popup maker for WordPress. Easy but powerful plugin with display filters, scroll-triggered popups, and Gutenberg block editor. — by Damian
What to do
- Update to the latest version (2.2.0.9). Anything older than 2.2.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get wp-popups-lite --field=version shows what you run; wp plugin update wp-popups-lite updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-24616 · published 2026-01-23
Missing authorization check in WP Popups (2.2.0.5 and older)
- Affected
- 2.2.0.5 and older
- Fixed in
- 2.2.0.6
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Damian WP Popups wp-popups-lite allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects WP Popups: from n/a through <= 2.2.0.5.
medium 5.3 CVE-2024-6555 · published 2024-07-12
Information disclosure in WP Popups (2.2.0.1 and older)
- Affected
- 2.2.0.1 and older
- Fixed in
- 2.2.0.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The WP Popups – WordPress Popup builder plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 2.2.0.1. This is due the plugin utilizing mobiledetect without preventing direct access to the files. This makes it possible for unauthenticated attackers to retrieve the full path of the web application, which can be used to aid other attacks. The information displayed is not useful on its own, and requires another vulnerability to be present for damage to an affected website.
medium 5.9 CVE-2024-29105 · published 2024-03-19
Stored cross-site scripting (XSS) in WP Popups (2.1.5.5 and older)
- Affected
- 2.1.5.5 and older
- Fixed in
- 2.1.5.6
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Timersys WP Popups allows Stored XSS.This issue affects WP Popups: from n/a through 2.1.5.5.
medium 5.4 CVE-2023-1905 · published 2023-05-08
Stored cross-site scripting (XSS) in WP Popups (older than 2.1.5.1)
- Affected
- older than 2.1.5.1
- Fixed in
- 2.1.5.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP Popups WordPress plugin before 2.1.5.1 does not properly escape the href attribute of its spu-facebook-page shortcode before outputting it back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks. This is due to an insufficient fix of CVE-2023-24003
medium 5.4 CVE-2023-24003 · published 2023-04-06
Stored cross-site scripting (XSS) in WP Popups (2.1.4.8 and older)
- Affected
- 2.1.4.8 and older
- Fixed in
- 2.1.4.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in Timersys WP Popups – WordPress Popup plugin <= 2.1.4.8 versions.
medium 5.4 CVE-2022-4716 · published 2023-01-23
Stored cross-site scripting (XSS) in WP Popups (older than 2.1.4.8)
- Affected
- older than 2.1.4.8
- Fixed in
- 2.1.4.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The WP Popups WordPress plugin before 2.1.4.8 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Recent activity
- 2026-10-26 — latest release on wordpress.org (2.2.0.9).
- 2026-01-23 — Missing authorization check disclosed (CVE-2026-24616), fixed in 2.2.0.6.
- 2024-07-12 — Information disclosure disclosed (CVE-2024-6555), fixed in 2.2.0.2.
- 2024-03-19 — Stored cross-site scripting (XSS) disclosed (CVE-2024-29105), fixed in 2.1.5.6.
Get an email when WP Popups has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for WP Popups (wp-popups-lite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Damian (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (4) · Missing authorization (1) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/wp-popups-lite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/wp-popups-lite"><img src="https://laskyr.com/plugins/wp-popups-lite/badge.svg" alt="WP Popups vulnerability status"></a>